[bug] alarm clock stays silent and can't be switched off at the same time

asked 2018-09-14 12:18:08 +0300

schmittlauch gravatar image

updated 2018-09-14 12:19:22 +0300

Today I overlept for 3 hours because the alarm on my Jolla1 went off, but didn't emit any alarm sound:
The device was switched on and the alarm UI was displayed. But trying to dismiss the alarm using the lower pulley menu entry didn't do anything, the alarm UI just stayed there in foreground silently.
No alarm sound was played though.

This issue isn't really reproducible, because it went away after a reboot. But I attached the journald log as it contains multiple suspicious entries like Sep 14 10:57:56 Sailfish timed-qt5[1236]: ERROR: Voland call 'create' failed, message: 'Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.' Sep 14 10:57:56 Sailfish mce[591]: tklock.c: tklock_datapipe_uiexception_type_cb(): uiexception_type = none -> alarm .

journald log ending during the time the bug appears

I hope you can take a look at this issue, because an alarm clock which doesn't work reliably is worthless.

I'm running Sailfish OS 2.2.1.18

edit retag flag offensive close delete

Comments

BTW: do you use the "mute when facing down" gesture ?

DrYak ( 2018-09-14 13:39:30 +0300 )edit

Yes, that setting was active (although I remember having it disabled).
But this shouldn't affect this issue as the phone was lying with the display upwards. And apparently the alarm UI was buggy as I wasn't even able to cancel the running (although silent) alarm.

schmittlauch ( 2018-09-16 21:57:35 +0300 )edit