Ask / Submit
1

Problem installing SailfishOS community edition on Gemini

asked 2018-10-05 22:04:24 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2018-10-07 02:47:46 +0200

ExPLIT gravatar image

I'm trying to install the latest SailfishOS community edition on my Gemini. It apparently flashes OK, I can boot into SailfishOS, and it asks me a couple of questions to set up (lcoale, time/date, set a security code), and then I'm left with a black screen with the SailfishOS spinner. It's been sitting and spinning like this for at least half an hour so far.

I don't even know how to start diagnosing this one, or what I could have done differently that might make a difference.

Edit: I've found that holding Fn-Esc for a couple of seconds brings up the theme/off menu, so I can change the colour of the spinner, or stop it, but I can't seem to do anything else.

edit retag flag offensive close delete

Comments

If you get the power off menu with Fn+ESC do a power off and power on the device with ESC (release when vibrates) and hold silver button pressed.

jolladiho ( 2018-10-05 23:45:12 +0200 )edit

I get the setup questions again, then when I finish the training, I get back to the spinner.

darkling ( 2018-10-05 23:59:09 +0200 )edit

I think that it was an error during your installation. Try to delete it and install again. However, If you have problems with a small number of your mobile applications installs, then I recommend you the service with android buy installs for your app. I wrote it, because I have used this service many times and like it.

lillytenwen ( 2018-10-09 11:19:20 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-10-07 02:47:03 +0200

ExPLIT gravatar image

updated 2018-10-07 02:47:19 +0200

this is also important to set up up your main sim card in android first, before booting to sailfish. otherwise you will have this black screen

edit flag offensive delete publish link more

Comments

Thanks. That worked.

I tried setting up Sailfish with the SIM in but without setting up in Android first, as suggested by depscribe, but that definitely didn't work. Going through the Android setup first, then rebooting to Sailfish got me to the main Sailfish desktop immediately. Problem solved.

darkling ( 2018-10-15 23:25:10 +0200 )edit
0

answered 2018-10-07 03:09:10 +0200

depscribe gravatar image

The only edition that works on Gemini is the one supplied by PC, 2.1.4.1. PC sent out a notice yesterday saying that a new version will be announced soon.

The comment about the SIM being in the device under Android first is not accurate. Mine, an Android/Linux/Sailfish triple boot X27, has never been booted to Android with a SIM card present, and it runs SFOS and its telephony just fine, the SIM inserted only after Sailfish was successfully installed and booting.

edit flag offensive delete publish link more

Comments

Configuring sim first under Android was mandatory on x27 I had for a loaner. Until that it was infinite spinner after tutorial.

Manatus ( 2018-10-07 10:09:00 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2018-10-05 22:04:24 +0200

Seen: 302 times

Last updated: Oct 07