Ask / Submit
2

Sailfish/Gemini: External speaker still on when headphones plugged in

asked 2018-10-19 20:16:10 +0200

darkling gravatar image

Pretty much as the title: the external speaker doesn't cut out automatically when the headphone socket is in use.

I'm using the Sailfish 2.1 community edition on an x27 Gemini.

edit retag flag offensive close delete

Comments

happened before, maybe this will solve your problem...

rgrnetalk ( 2018-10-19 20:31:46 +0200 )edit

OK, reading that, it seems that booting with the headphones plugged in should help... but not in my case. I've also tried various combinations of plugging/unplugging with playback running, or not. Also restarting the media application with headphones present or not. I've seen no change in behaviour from any of this.

darkling ( 2018-10-20 01:37:39 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-10-27 15:26:11 +0200

mane gravatar image

Same here.

edit flag offensive delete publish link more

Comments

This is not an answer, please refrain from using Answer boxes for simple comments. Use 'add a comment' as shown under the comments from the last user.

Welcome to TJC.

Edz ( 2018-10-27 16:08:11 +0200 )edit
0

answered 2018-11-05 07:44:05 +0200

mane gravatar image

updated 2018-11-05 07:45:30 +0200

Tuning pulseaudio works, altrough this might foward everything (ringtones for example) to your headphone jack.

$ pacmd list-sinks

Prints details of your audio setup. One that's your default is marked with a star:

* index: 1

On my Gemini PDA, headphones were inside "index 1 ---> ports ---> output-wired_headphone"

$ pacmd set-sink-port 1 output-wired_headphone

Changes to the headphone jack. This will reset after rebooting back to speakers, i tried adding that line to /etc/pulse/default.pa but it didn't work.

(EDIT: typo on last command)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2018-10-19 20:16:10 +0200

Seen: 232 times

Last updated: Nov 05 '18