Ask / Submit
4

Android app "trainline.eu" complains about "no internet connection available"

asked 2018-10-29 13:22:18 +0200

jollajo gravatar image

Since the app "DB Navigator" of Deutsche Bahn refuses operation due to missing TLS 1.2 support I switched to the android app trainline.eu. Yesterday, however I realised it also stopped working on my Jolla C with SFOS 2.2.1. It complains "No internet connection available.". Other android apps don't have an issue with internet access. Also tried to uninstall, reinstall, clean cache, clear local data, nothing helps, as soon as I try to browse the time table I get this message.

On my old Nexus10 tablet with LineageOS v11 it works without any issues. I haven't found any reports on the net that the service requires anything special recently. Can you confirm if it works for you or if it's broken as well?

edit retag flag offensive close delete

Comments

Could native app 'fahrplan' supply the information for you?

rgrnetalk ( 2018-10-29 14:45:27 +0200 )edit
1

@rgrnetalk Well, my main usage of DB Navigator and Trainline.eu was to buy and archive tickets, this is not supported by fahrplan, AFAIK

jollajo ( 2018-10-29 14:56:48 +0200 )edit
1

I've had a similar issue with a few Android applications on the Jolla Tablet, in my case it apparently only works after restarting the Android support (or rebooting the device). All other applications work just fine, so I'm guessing that these non-working applications check for network connectivity in an abnormal way, and the Android support doesn't properly re-enable all network settings if the connection has been lost and restored.

nthn ( 2018-10-29 17:23:23 +0200 )edit

@nthn good point, tried that already, even re-installation didn't change anything. I've tried rebooting, restarting AlienDalvik, force stop, clean cache, delete local data without any success.

jollajo ( 2018-10-29 20:28:41 +0200 )edit

Same issue for me :-( On my J1 (alien dalvik android 4.1) or on the Aquafish intex of my wife (as Jolla C & Alien Dalvik android 4.4). I also tried to downgrade the 44 Trainline version to the 43 on my Jolla 1. But no effect :-( Have you an idea oh this trouble ? I am quite a big user of the trainline app !

mips_tux ( 2018-10-30 15:55:39 +0200 )edit

4 Answers

Sort by » oldest newest most voted
4

answered 2018-12-24 16:08:36 +0200

mips_tux gravatar image

updated 2018-12-24 16:16:46 +0200

Hello

Trainline has released version 45 of its application. It seems to solve the impossibility of connecting of the version 44. From now on, the application sends a popup indicating that in order for the connection to be secure, it is necessary to install Google Play. Just reject the proposal and the application seems to work properly. However, not having a train ticket to buy at this time, I could not test this version 46 until the end :-( Thanks for your tests !

edit flag offensive delete publish link more

Comments

FWIW the UK app, just called Trainline (you can't buy UK tickets in the UK with Trainline.eu) is at v42 in Jolla's Android Store. The one on G-Play, installed on an Android device, is v55 and was last updated in July 18.

DaveRo ( 2018-12-24 19:20:42 +0200 )edit

yes !! I forget to say that i was speaking of trainline.fr/trainline.eu And the app seems OK at this time (i don'y buy any tickets for the moment): https://play.google.com/store/apps/details?id=com.capitainetrain.android&hl=fr but download with YalpStore

mips_tux ( 2018-12-25 00:51:57 +0200 )edit

Downloaded and installed Version 45 in my JollaC on SF3, you get quite a few warnings regarding missing GAPPS however buying a ticket for Deutsche Bahn worked like a charm. When you present a new connection it doesn't show the city option (free local transport) but you get it with the ticket. Also 'frequent flyer' program (bahn.bohnus) should be rewarded if you've registered your discount card (bahn.card) with Trainline.eu.

jollajo ( 2018-12-25 21:58:07 +0200 )edit

The latest Trainline UK version - 55 - won't install. Message: needs Android 21. Another case of needing an upgrade to Alien.

DaveRo ( 2018-12-25 23:29:51 +0200 )edit

I installed version 45 from Aptoide yesterday and YES!!! it works on my Xperia X, finally able to launch the app and display my e-tickets :)

cartron ( 2018-12-28 14:50:25 +0200 )edit
3

answered 2018-10-31 13:53:27 +0200

jollajo gravatar image

To answer my own issue: I addressed that issue to trainline.eu via twitter and got the reply that they made changes to increase security. This would exclude some older versions of Android.

So I assume that they now also require TLS1.2 and they can't be bothered to add a single line of code (s.setEnabledProtocols(new String[] { "TLSv1.2" });) I answered that it's up to them to neglect a certain group of customers, however due to their missing communication and shitty error message (No internet connection available) the waste a lot of time on the users side trying to identify the root cause. I'm rather pissed off.

edit flag offensive delete publish link more
0

answered 2018-11-11 15:56:52 +0200

mips_tux gravatar image

updated 2018-11-11 16:00:02 +0200

The only solution : Xperia XA2 with Sailfish X 3 ?

https://together.jolla.com/question/186788/android-apps-are-requiring-lollipop-api-21-and-tls-12/

See also : https://together.jolla.com/question/183137/how-to-import-tls-certificate-into-android-support/

edit flag offensive delete publish link more

Comments

What are you trying to tell us with posting those two links?

Do you have any knowledge whether that issue with trainline.eu is related to an unknown certificate or does the server require TLS 1.2. So far I cannot see any information that qualifies your post as an answer.

jollajo ( 2018-11-11 23:45:06 +0200 )edit
-1

answered 2018-10-31 15:37:19 +0200

DrYak gravatar image

as an alternative to Android Apps, I would strongly recommend the native Fahrplan by Smurfy (also available in the Jolla shop).

It supports multiple back-ends, and is open source.

edit flag offensive delete publish link more

Comments

1

yes but you can't buy and store tickets :-( And Fahrplan does not work for France :-(

mips_tux ( 2018-10-31 15:55:04 +0200 )edit

@mips_tux you are correct and unfortunately this will not come to SFOS. It's one of those things you have to live without. See my comment above on what I do.

Desmo ( 2018-10-31 18:31:30 +0200 )edit

Same here, I cannot really understand why "more security" means that as a sailfish user (on Xperia X) I am excluded from the only reasonable alternative to the incredibly dysfunction oui.sncf app...

wcr ( 2018-11-11 13:45:03 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2018-10-29 13:22:18 +0200

Seen: 769 times

Last updated: Dec 24 '18