Ask / Submit
13

HowTo: Connecting to Jolla via SSH over USB [answered]

asked 2013-12-25 23:34:19 +0300

SieniMaagi gravatar image

updated 2014-02-27 00:30:29 +0300

jgr gravatar image

Hi all,

As I'm a Windows n00b and haven't used SSH/Linux/similar stuff too much in my lifetime, I'm having problems connecting to my Jolla phone via SSH (in USB Developer Mode) and I couldn't find good instructions on that from anywhere, and I thought that perhaps someone could answer this with proper instructions, and it could be a wiki answer at the same time, so other people won't have the same problems as I do.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by pnuu
close date 2013-12-26 11:50:59.956451

Comments

3

I made this for wifi, it might help you : https://together.jolla.com/question/28095/howto-ssh-jolla-on-windows-over-wifi/

Dam ( 2014-02-15 18:34:56 +0300 )edit

For people using Linux and NetworkManager app, note that if you want to keep your computer internet connection working when connected to Jolla over USB (with developer mode), you have to go to the IPV4 settings tab of NetworkManager, then click "Routes" button and then check "Use this connection only for resources on its network (If enabled, this connection will never be used as the default network connection)".

baptx ( 2014-09-25 22:53:52 +0300 )edit

4 Answers

Sort by » oldest newest most voted
18

answered 2013-12-26 00:27:00 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-02-27 00:19:31 +0300

jgr gravatar image

This way under Windows. ( tested with windows 7 and 8 )

  1. Connect the jolla phone using the USB cable and select "developer mode" when the pop-up menu appears on the phone

  2. In windows network settings will appear a new ethernet interface named "Remote NDIS based Internet Sharing Device"

  3. So go to poperties of this adapter and assign an ip address ( TCP/IP v4 ) in the same subnet of ip address assigned in developer mode ( 192.168.2.x )

  4. Download putty or any other terminal client for windows and connect to the phone at the ip address 192.168.2.15; the user is "nemo" and the password is the one you have placed into developer mode of jolla phone.

  5. just logged in write: devel-su to gain root access ( same password of before ) and set a password for the root user ( write: passwd root ), so next time you can directly login with root user

edit flag offensive delete publish link more

Comments

Could you be more specific with "windows network settings" My maschine is running Windows 8 and I dont event get any kind of message when I connect my Jolla to my PC after the last Jolla Update.

Kelteseth ( 2014-03-18 13:32:07 +0300 )edit
1

I just connected through USB my device and Windows XP SP3 cannot find an NDIS driver to install and it reports that my hardware cannot be used. Also even though I have my device's settings for USB connection to be in developer mode, after a few seconds I hear the disconnection sound and the device reports that it's charging. So I cannot deploy my game onto the device.

hamlatzis ( 2014-03-26 09:48:24 +0300 )edit
1

In windows 7 (64bit), open "Network center" in the control panel, then click "change adapter settings". Open the right connexion (one can see "Remote NDIS based Internet Sharing Device"). Click "Properties". In the Checkbox, click "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties" below. you have then to check "use the following IP adress". In "IP adress" : 192.168.2.14, in subnet mask "255.255.255.0". "OK".

smartiz ( 2014-05-01 15:16:49 +0300 )edit

"Remote NDIS based internet sharing device" used to be installed and working onto my Win7Pro computer (with erratic disappearances and frequent re-installations required). Now for unknown reasons this device no longer appears when my Jolla is connected through USB, so RNDIS driver couldn't be re-installed. Microsoft mysteries... Using wifi instead for now.

objectifnul ( 2015-04-10 12:48:08 +0300 )edit
13

answered 2013-12-25 23:38:50 +0300

vbmithr gravatar image

updated 2013-12-25 23:39:40 +0300

This should work under Linux.

  1. Enable developer mode on Jolla
  2. Plug it on your Unix computer with USB, click on "developer mode" when the pop-up menu appears on the phone.
  3. Do ifconfig usb0 inet 192.168.2.14 as root on your Unix machine (The name can be something else than usb0 under other unices than Linux).
  4. Do ssh nemo@192.168.2.15 on your Unix machine (as a normal user).

This should work.

edit flag offensive delete publish link more

Comments

Yeah, but how about Windows environment?

SieniMaagi ( 2013-12-25 23:40:42 +0300 )edit

Based on the wording in the question, I believe the need was for Windows.

pnuu ( 2013-12-25 23:42:20 +0300 )edit

Use putty for SSH. I have no idea regarding the network interface. Under Linux plugging the Jolla in makes Linux believe it has a new network interface attached that it can use. It should be roughly the same on Windows. At least I hope so :)

vbmithr ( 2013-12-25 23:43:04 +0300 )edit

Yeah but I thinks there's a step missing in Windows env as after plugging the dev-mode USB in, putty can't connect to the address, so I'm thinking there's some kind of problem with the IP address?

SieniMaagi ( 2013-12-25 23:44:52 +0300 )edit
2

Under Kubuntu 12.04 I did exactly as described above to set up the SSH connection. The following error message in terminal is "ssh: connect to host 192.168.2.15 port 22: Connection timed out" and nothing really happens. Any idea what I missed? Also I tried using Putty, typed in the IP-address 192.168.2.15 with port at 22 and the connection cannot be established. I would be really glad for a step-by-step description of how to use Putty to establish the desired SSH connection. Thanks!

Deonith ( 2014-02-07 00:05:16 +0300 )edit
3

answered 2013-12-26 00:10:53 +0300

Faz gravatar image

I appreciate you're asking via USB, but I've always found connecting via WiFi easier, with this and other Linux based phones. Unless you have particular reason to use USB I think you'll find SSH via wireless easier and more practical.

e.g. To find out the IP address of your phone install "IP Address" from the main Jolla app store. Then using Putty enter this IP as the host (to the left of 22), enter Jolla (or other description) just below "Saved Sessions", then click Save. Whenever you open Putty you can now just double click Jolla to SSH to your phone, assuming your home network maintains same IP, which is quite common. Make sure you always login with username "nemo" first. To then enter root/superuser type "devel-su". Password for both should be the one you set when you enabled Developer mode on the phone. Be careful (especially when logged in as root) as there's potential to brick device.

Checkout The One Page Linux Manual for a good run down of Linux commands. Just remember, Linux is unforgiving compared to Windows and will assume you know exactly what you're doing so please do be careful.

edit flag offensive delete publish link more

Comments

4

the IP address of the device is displayed in

Settings/Developer mode

So no need for an extra app

ortylp ( 2013-12-26 00:22:55 +0300 )edit

Nice! For both WLAN and USB interfaces too! Thanks @ortylp :)

Faz ( 2013-12-26 03:11:46 +0300 )edit

There are several good reasons to connect to Jolla via USB instead of WiFi:

  • If you're already connected to a WiFi network on your computer, you can stay connected and use USB transfers without connecting your phone to your wireless router (and it prevents useless usage of your router to communicate with your phone).
  • You can connect to WiFi by creating an Ad-Hoc network on your phone like when you're sharing Jolla's internet connection (note that if your computer is already connected to another WiFi network, you have to disconnect which can stop your downloads or other connections) but in my case I got a very low transfer speed: 3 MB/s via WiFi instead of 13 MB/s via USB.
baptx ( 2014-09-27 15:36:26 +0300 )edit
0

answered 2013-12-25 23:57:12 +0300

rainisto gravatar image

Currenltly on windows you need manually setup your RNDIS interface ip to 192.168.2.14 (by default windows uses DHCP and its not getting any ip on that interface). But afterwards it should work, at least works on my Windows 8 machine.

edit flag offensive delete publish link more

Comments

1

Yeah I think this is what I'm looking for, but stupid people need simple answers: so how do I set the RNDIS interface ip to that?

SieniMaagi ( 2013-12-26 00:22:14 +0300 )edit

On Windows 7 (64-bit) I found it very straight forward to install and use WinSCP (free) to transfer files to and from the Jolla whilst it was charging in a wall-socket over WIFI. Full control and no need for commandline utils, very handy when only shuffling files.

trashin ( 2014-04-12 23:13:28 +0300 )edit

Question tools

Follow
17 followers

Stats

Asked: 2013-12-25 23:34:19 +0300

Seen: 16,997 times

Last updated: Feb 27 '14