Ask / Submit
16

[BUG] [3.0.0.5] [3.0.0.8] Display of email-attachments is broken

Tracked by Jolla (In progress)

asked 2018-11-05 16:20:31 +0200

31415926ZZA gravatar image

updated 2018-11-09 21:08:49 +0200

melg01 gravatar image

I just noticed that the display of pdf email-attachments doesn't work correctly anymore since i updated my J1 to 3.0.0.5: The display of the pdf attachments is corrupted in the Documents app (scrambled text / only fragments are displayed). I further noticed that it only affects pdf-attachments which i haven't opened before the update. So "older" pdf-attachments which were already opened/downloaded on my J1 before the update are displayed correctly.

The pdf files are displayed correctly in the Documents app if being transfered directly to my J1 via sftp from my PC.

I'm using an Exchange-account for email. The server is an Exchange Server 2013. Because it's the only email-account on my phone, i can't test whether the bug is affecting other account-types as well.

[Edit 06-11-2018] It seems all email attachments get corrupted when downloading from an Exchange mailbox.

edit retag flag offensive close delete

Comments

Can confirm with xperia X and exchange server. PDF attachments open but are corrupted.

saturn ( 2018-11-05 22:57:56 +0200 )edit
1

Might be activesync specific error. PDFs downloaded and opened via IMAP seem to work ok.

Manatus ( 2018-11-06 00:17:55 +0200 )edit
1

Cannot open password protected PDF files on exchange either, Work fine in ordinary IMAP email accounts.

rogger888 ( 2018-11-06 01:37:01 +0200 )edit
1

It seems the issue is not specific to PDF attachments, but to all attachments. Also other file types, such as images and documents, are corrupted when downloaded from an Exchange mailbox. As such, this has to be considered as a major bug.

ziellos ( 2018-11-06 12:40:48 +0200 )edit

this is catastrophic. again, no one seems to care for business users at jolla. i'm really upset not being able to read attached pdfs anymore. i expect a quick patch for this.

melg01 ( 2018-11-07 06:48:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
7

answered 2018-11-12 15:19:10 +0200

Pekka Vuorela gravatar image

A rather nasty bug here, but I think I found the issue. Apologies for inconvenience, should have catch that earlier.

edit flag offensive delete publish link more

Comments

1

Thank you! And while working on it, maybe you could also solve the very old issue of not being able to open mails sent as an attachment inside another mail... now this would compensate for some frustration with the bug here described... :-)

melg01 ( 2018-11-13 00:17:34 +0200 )edit
0

answered 2018-11-09 00:50:57 +0200

melg01 gravatar image

updated 2018-11-09 22:40:10 +0200

Original post started with: "Well, not really an answer, but they just don't care" (rest of ranting message deleted).

OK, I apologize again if I was too rude, it was never intended to hurt anyone on a personal level. And yes, I still support Sailfish since the very first version. And I have been since then one of those apparently few who want a mobile OS alternative suited for daily business use as well.

I don't talk about missing apps and lack of basic functionalities, even less dreaming about user space innovations. I'd be just happy with a solid and stable basic OS, so, please please, don't break important already existing features after every major update, double test and crosscheck the new releases. And rethink your process steps between pre-release and final release, which was definitely too short this time.

I will have to change back to Andr* (cough, cough) for a couple of months, until those things get fixed again. How about Jolla caring for those users too, who proudly show the Sailfish OS at their business meetings? (but are now ashamed if they get a document and can't open it...!) It's a bumpy road, I know. Good luck to all.

edit flag offensive delete publish link more

Comments

If the problem is reported here on Monday and there is no fix by Thursday, it hardly means that nobody cares. Yes, the problem is rather serious and should be fixed as soon as possible, but sometimes fixing problems may take more than four days even if one works hard for it. Yes, it really sucks if this kind of a bug ends up into a published version, but I don't see a reason to draw this kind of conclusions even if it happens and it takes a while to release a fix.

kkarioja ( 2018-11-09 16:07:29 +0200 )edit
3

A bug of this severity should have been enough to hold back the 3.0.0 release in early access status until a fix is available. The bug is not even listed in the "known issues" section of the release notes, so it really seems Jolla doesn't care at all. Thankfully we have light ambiences now.

ziellos ( 2018-11-09 21:30:55 +0200 )edit

Let's just hope they fix it soon. I won't update until it is fixed.

BonoNL ( 2018-11-10 22:28:55 +0200 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2018-11-05 16:20:31 +0200

Seen: 861 times

Last updated: Nov 12