Ask / Submit
1

XA2 H4113 stuck at sony logo after flashing, can't power off / reboot

asked 2018-11-08 21:57:30 +0200

lethe gravatar image

I tried to flash my XA2 dual sim (H4113, Rev. 3) using Sailfish_OS-Jolla-3.0.0.8-h4113-0.0.7.10. After error-free flashing it is now stuck at the white sony logo screen and I can't power it off. I tried holding the power button (for at least 2 minutes), but it just won't power off or reboot.

Is there any way besides the power button to reset the device? I started with a full battery when flashing, so I seriously hope I don't have to wait for the battery to deep discharge...

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
2

answered 2018-11-08 22:47:20 +0200

mal gravatar image

You can force power off in Sony Xperia devices by pressing volume up and power buttons at the same for a few seconds until the device vibrates 3 times in a short time after which release the buttons and it should be powered off.

Regarding the stuck at boot logo please check https://together.jolla.com/question/192632/xa2-h4113-bootloops-after-flashing-trial-3008/?answer=192678#post-id-192678

edit flag offensive delete publish link more

Comments

Thanks mal, that did the trick! Have not tried the fastboot fix yet, but the comments on that thread don't give me much confidence it'll work... :/

@Jolla: It would be nice, if that combination would make it into the troubleshooting section of the readme. I tried searching the web, but all I could find were guides on how to do a factory reset...

lethe ( 2018-11-08 22:56:58 +0200 )edit

Note that the early comments were for a partial fix (not reflashing the whole image after boot image flashing) so flash the kernel to boot_b and then reflash the whole installation using flash.sh (or which ever version you use of that). That should help. If not then you can try the additional set_active command found in the comments, and reflash also after that also.

mal ( 2018-11-08 23:01:43 +0200 )edit

Thanks, I managed to SailfishOS to boot using flashing the boot_b image & using set_active (boot_b by itself would not do the trick).

lethe ( 2018-11-08 23:36:37 +0200 )edit
0

answered 2018-11-08 23:40:23 +0200

PAMPKIN gravatar image

updated 2018-11-08 23:41:06 +0200

Please download and use Sony Flash Tool called Emma from this site:

https://developer.sony.com/develop/open-devices/get-started/flash-tool/download-flash-tool/

follow with steps from this instructon:

https://developer.sony.com/develop/open-devices/get-started/flash-tool/how-to-flash/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-11-08 21:57:30 +0200

Seen: 359 times

Last updated: Nov 08