Ask / Submit
6

Media app doesnt show any Music files on encrypted SD

asked 2018-11-09 15:43:31 +0300

MadMe86 gravatar image

updated 2019-06-13 12:09:16 +0300

rozgwi gravatar image

Hello!

I installed SFOS yesterday on my XA2. Really great OS!

I also found the rsync on the Command Line(i'm in love :-D) so i synced my Music from my NAS to my Phone. Its much to big for the internal storage. so i put it on the encripted SD Card(256GB).

But the media App shows only 0 Titles... Is the encription the problem? Any other hints?

I also tried to rescan the media database with the tools in the settings. didnt work for me :(

Greetings MadMe :)

bump:
occurring on Xperia X / 3.0.2.8 and 3.0.3.10 as well

edit retag flag offensive close delete

Comments

Just a guess, the SD card is not on the paths indexed by the tracker. Maybe try https://openrepos.net/content/velox/talefish for the time being?

bomo ( 2018-11-09 16:09:48 +0300 )edit

That makes sense... i already found Muuzik! player and works great for me :)

MadMe86 ( 2018-11-09 16:40:59 +0300 )edit

Sometimes a restart helps after removing the DB with Sailfish Utils from settings -> utilities

leszek ( 2018-11-09 17:19:24 +0300 )edit
3

i just kick started it with:

tracker index -f /media/sdcard/XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX/Music/*

must say extremly fast... not even a minute... on my android phones it was about 30 Minutes

MadMe86 ( 2018-11-09 17:58:25 +0300 )edit
1

@MadMe86 How much you have music in your sdcard? In short; I'm just curious about speed comparison android vs sailfish.

Jk ( 2018-11-10 03:00:11 +0300 )edit

1 Answer

Sort by » oldest newest most voted
11

answered 2018-12-11 13:43:28 +0300

carmenfdezb gravatar image

Hi @MadMe86!! I had the same issue as you, media app didn't showed music from my encrypted sd card, but the same was happening with Gallery app: it didn't showed images. I used tracker index to solve it:

tracker index -f /run/media/nemo/<card_name>/*
edit flag offensive delete publish link more

Comments

1

Thank you!

Kopekenscheich ( 2018-12-11 19:18:30 +0300 )edit
1

Probably the tracker path settings patch (patchmanager web-catalogue) will help. There I explicitely inserted my media directories in "included recursive directories"

cy8aer ( 2019-04-18 12:06:26 +0300 )edit
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2018-11-09 15:43:31 +0300

Seen: 505 times

Last updated: Jun 13