Ask / Submit
26

jolla1: net using android apps don't start or are unusable slow while offline

Tracked by Jolla

asked 2018-11-09 21:04:43 +0200

Marcel Pol gravatar image

updated 2019-05-09 16:43:53 +0200

mips_tux gravatar image

On my Jolla 1 with 3.0.0.8 Whatsapp doesn't start when the network is down. Connecting again makes it start again. I also tried to start Firefox, which does start, but takes a long time. I don't remember this happening on earlier release. At first I though Alien Dalvik was broken and restarted the phone, and sometimes it worked. But it seems to be a network issue.
while running firefox, dmesg output is:

[  481.381779] app_process(4317) send signal 3 to Signal Catcher(4317)
[  481.992888] mozilla.firefox: unhandled page fault (11) at 0x40001000, code 0x81f
[  481.992888] pgd = d2f8c000
[  462.501815] SLIM_CL: skip reconfig sequence
[  481.992919]     [40001000] *pgd=9e6e0831    
[  481.992919] , *pte=b79606df, *ppte=b796065f
[  481.992949] Pid: 4416, comm:      mozilla.firefox
[  481.992980] CPU: 0    Tainted: P        W  O  (3.4.108.20181002.1 #1) 
[  481.992980] PC is at 0x5f5e74dc
[  481.993010] LR is at 0x5f5e74d9
[  481.993010] pc : [<5f5e74dc>]    lr : [<5f5e74d9>]    psr: 00000030
[  481.993041] r10: 40b65b1c  r9 : 40497288  r8 : ffffffff
[  481.994262] r7 : 00000000  r6 : 40001000  r5 : 5f6eda70  r4 : 5f6eda54
[  481.994262] r3 : 3b9aca00  r2 : 00000000  r1 : be803388  r0 : 0000007b
[  481.994292] Flags: nzcv  IRQs on  FIQs on  Mode USER_32  ISA Thumb  Segment user
[  481.994292] Control: 10c5787d  Table: 9318c06a  DAC: 00000015
[  481.994323] [<c010b73c>] (unwind_backtrace+0x0/0x118) from [<c010f658>] (__do_user_fault+0x6c/0xb4)
[  481.994353] [<c010f658>] (__do_user_fault+0x6c/0xb4) from [<c08a36a4>] (do_page_fault+0x358/0x3e8)
[  481.994628] [<c08a36a4>] (do_page_fault+0x358/0x3e8) from [<c01002f8>] (do_DataAbort+0x134/0x1a8)
[  481.994658] [<c01002f8>] (do_DataAbort+0x134/0x1a8) from [<c08a1f14>] (__dabt_usr+0x34/0x40)
[  481.995666] Exception stack(0xde417fb0 to 0xde417ff8)
[  481.995696] 7fa0:                                     0000007b be803388 00000000 3b9aca00
[  481.995727] 7fc0: 5f6eda54 5f6eda70 40001000 00000000 ffffffff 40497288 40b65b1c 00000001
[  481.995727] 7fe0: 5f6ec474 be803368 5f5e74d9 5f5e74dc 00000030 ffffffff
[  481.995757] mozilla.firefox(4416) send signal 11 to mozilla.firefox(4416)
[  482.360628] app_process(4440) send signal 3 to Signal Catcher(4440)
[  542.084236] ActivityManager(4103) send signal 3 to mozilla.firefox(4416)
[  553.077643] [WH Lee] taos_als_enable::on=0, rc=0

[edit] 3.0.1.11 does not fixed this issue on my J1

[edit] 3.0.2.8 does not fixed this issue on my J1 :-(

[edit] 3.0.3.9 does not fixed this issue on my J1 :-(

edit retag flag offensive close delete

Comments

2

On my Jolla 1, now in version 3 I noticed a rather curious thing : if you use K9mail or OsmAnd without being connected to a network (data or wifi), these two programs become particularly long or unusable.

For example, if my Jolla is not connected to the net, the rotation in OsmAnd becomes very slow and you go through a black screen that lasts for a long time ...before the screen comes back.

The same for K9mail: it becomes almost impossible to open a mail unless you wait for very long seconds.

I didn't have this behavior with version 2.2 and earlier. And reboot, clear the cache, stop and run android support ... do nothing.

My issue seems a lot of your issue.

mips_tux ( 2018-11-15 12:33:26 +0200 )edit

This bug is really curious : i found no solution for my J1. But our Intex Aquafish (as Jolla C) is not affected by this issue. The différence between our J1 and Aquafish is that the Aquafish have Google Play Services installed.

So for the moment K9mail and OsmAnd are not usable without data/wifi connection "on"

mips_tux ( 2018-11-19 10:12:54 +0200 )edit

I have the same issue as well, both for the Telegram and LINE android apps (also on Jolla 1)

CHZK ( 2018-11-19 10:18:04 +0200 )edit

I don't think there is a solution doable by users: jolla changed something in how network connection is forwarded to aliendalvik and this now produces pagefaults if not connected...

lpr ( 2018-11-19 10:21:37 +0200 )edit

yes.. the other difference between our J1 and Aquafish (as Jolla C) is that the j1 was update to the version 3 with the command line (the graphic way was not functionnal) and the Aquafish was update without the help of the command line.

mips_tux ( 2018-11-19 12:20:35 +0200 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2019-01-27 13:50:04 +0200

mips_tux gravatar image

A beginning of workaround ? Put your smartphone on "fly mode" without any data connections : k9mail works well !!! OsmAnd too ! And may be all Android apps. Please at Jolla : find a solution in the next realese ;-)

edit flag offensive delete publish link more

Comments

This sometimes works for me - my android apps with this problem are maps.me and jorte calendar. I guess these may be trying to do network accesses and timing out. Other android apps which do not do any network accesses do not have any problems anyway.

antw ( 2019-01-29 04:46:14 +0200 )edit

Thanks, the workaround worked. Hope GPS will work in fly mode.

seehas ( 2019-05-04 23:04:19 +0200 )edit
0

answered 2018-11-14 09:00:11 +0200

vm5 gravatar image

Same problems for me with Jolla 1. Sometimes i have to reboot the wlan.

edit flag offensive delete publish link more

Comments

5

@vm5 Then you should upvote the question and convert this answer to a comment. :D

Alex ( 2018-11-14 09:43:18 +0200 )edit

reboot the wlan or reboot my j1 do nothing on this issue :-(

mips_tux ( 2018-11-19 13:17:38 +0200 )edit
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2018-11-09 21:04:43 +0200

Seen: 930 times

Last updated: May 09