We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Mail App - accounts invisible & "Problem with sync" [answered]

asked 2014-01-24 12:46:57 +0300

ajack gravatar image

updated 2014-01-24 13:13:38 +0300

I've set up 2 IMAP accounts(GoogleApps as standard IMAP account and other standard IMAP e-mail) in Settings>Accounts.

When I go to mail app and try to sync "Problem with sync" error appears.

Accounts aren't listed in the e-mail app. Once I added a 3rd, test Gmail account one of them became visible. GMail account works, standard IMAP don't.

I use WiFi only for now.

Any suggestions how to make this work would be appreciated :). Also, please write if you have any suggestions on how to investigate this further(finding error logs, testing).

Thanks.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2014-01-24 19:59:24.875322

Comments

same problem...

akira1980 ( 2014-01-24 13:29:11 +0300 )edit

"Accounts aren't listed in the e-mail app. Once I added a 3rd, test Gmail account one of them became visible. GMail account works, standard IMAP don't."

Did you try to scroll the list of accounts in the email app ? :) in case the email app was open when you created the new account, it can go at top of the list.

Which account does not work ? Standard IMAP ? Is that a big/known service or your own server, if later what email server is used there ?

Thanks.

VDVsx ( 2014-01-24 17:23:44 +0300 )edit

I had a similar problem when deleting and re-adding an account, because it did not sync anymore. After re-adding the account it did not immediately pop up in the e-mail app. As far as I remember I did not do anything special (reboot?, sync?) but after a while I could see it in the e-mail app. I have currently 5 accounts set up, both IMAP and POP3. All of them work now without problems. MAybe a "bug" tag should be added?

Jörg ( 2014-01-24 18:10:39 +0300 )edit

@Jörg - If you can reproduce that, please open a new entry for better visibility, since the original issue was other. See my answer above about scrolling the list if the app is open, accounts should appear immediately in the email app if the email service is on.

VDVsx ( 2014-01-24 20:01:28 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-24 18:50:27 +0300

ajack gravatar image

While testing I realized, that "Allow apps to send and receive email with your Email account" option in Email settings should be turned on. It works now. I thought the option relates to 'external apps', not default Sailfish Email. Thanks all:).

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2014-01-24 12:46:57 +0300

Seen: 467 times

Last updated: Jan 24 '14