We have moved to a new Sailfish OS Forum. Please start new discussions there.

Sailfish times out while writing the WiFi password [duplicate]

asked 2014-01-24 20:48:20 +0300

AxMi-24 gravatar image

updated 2014-07-11 23:34:10 +0300

simo gravatar image

The issue is that the phone seems to have a certain time limit on how long you are allowed to type the password and after that period it just says "can't connect to network".

The WiFi password in question is long and complicated and I can't manage to type it in fast enough. This is a clear security issue as it forces users to use short simple passwords.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Anna
close date 2014-01-26 06:00:17.452428


I have the same issue but it does not affect the ability to set the password correctly. I think only the connection check to ipv4.jolla.com is failing and thus the error message is thrown. But after saving the password everything is fine.

Sailor ( 2014-01-24 21:07:47 +0300 )edit

Mine just kicks me back to retyping the password so I never get a chance to type it all in.

I did find a workaround with devel mode

[wifi_xxxxxxxxxx_SSID(fill in your SSID)_managed_psk]
Passphrase=xxxxxx (password without any qutation marks and yes it can handle space and quotation mark in the actual pswd)

This is the format of the wifi settings file. So what can be done is to change pswd, connect and get this file generated and then create the same one on your PC (ANSI encoding) and copy it to the phone then co in dev mode and overwrite the old settings file with the good pswd.

Not very useful other than at home but at least it enabled me to use a secure password.

AxMi-24 ( 2014-01-24 21:59:41 +0300 )edit

The timeout for inputting a password/passphrase is the connman default of 2 minutes. What do you think would a better timeout for this? 3 or 4 minutes?

llornkcor ( 2014-01-25 04:10:45 +0300 )edit

I almost managed to type mine in and it's probably as bad as it gets. It did take me a few tries to get that fast so I would say 5 minutes should be safe for most people.

AxMi-24 ( 2014-01-25 10:16:11 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-01-26 01:27:25 +0300

bara gravatar image

Not a solution, but an easy workaround for now:

  • Open an application where you can type in a field.
  • Type your password there
  • Copy and paste it to the connection dialog.
edit flag offensive delete publish link more

answered 2014-01-26 02:25:00 +0300

Anna gravatar image

This is a duplicate of this https://together.jolla.com/question/2285/wlan-not-enough-time-to-enter-a-password-for-ssid/

edit flag offensive delete publish link more

Question tools

1 follower


Asked: 2014-01-24 20:48:20 +0300

Seen: 244 times

Last updated: Jan 26 '14