Ask / Submit
2

[Xperia X] SIM cards not recognized

asked 2018-11-20 15:28:10 +0300

hammerhead gravatar image

updated 2019-02-15 17:36:18 +0300

My Sony X stopped recognizing my SIM cards.

I do see the bar that indicates signal quality, but it stays empty. Also, the phone does not ask me for the PIN code.

However, when I pull out the SIM/SD cartridge, it usually tells me that the SIM card has been removed and that I'd need to reset my phone in order for it to work. The SD card, which is inserted with the same cartridge, is recognized and I am able to access the data on it.

In order to check if SIM slot 2 was working, I removed the SD card and placed the SIM card in its slot. The behavior stayed the same.

I also tried two different SIM cards after verifying that both of them do work correctly in other phones.

Then I used my secondary Sony X and inserted the very same cartridge there. It correctly recognized the SIM in all Sailfish versions on that phone (version 2.1, version 2.2 and the current version 3.0.0.8)

Maybe this is a hardware issue, but I'd like to be sure before changing phones.

What can I do to debug this issue further?

edit retag flag offensive close delete

Comments

I experienced a weird glitch with the Xperia X, in Android, whereby it would recognize the presence of a sim, even showing the number in one of the settings menu options and Whatsapp would work (having already been setup), but it would not send/receive calls or texts.

I tried a factory reset, but had no joy.

Try reflashing with Android to see if the handset suffers from the same issue.

rgp ( 2018-11-20 19:15:36 +0300 )edit

Uff. I'd much rather get some debugging output first. Reflashing would mean hours of re-configuration.

hammerhead ( 2018-11-21 14:16:12 +0300 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2019-02-15 17:39:48 +0300

hammerhead gravatar image

TL;DR: Going into fastboot mode and doing a fastboot reboot might have had the effect of resolving this issue.

After using the phone without GSM services since my original post for a couple of months, this happened: i was browsing the web when the phone completely froze. The website just remained on the screen and I couldn't even turn it off.

I plugged the USB cable to see if charging would unfreeze it. The screen went black and the red LED lit up. Whatever I did, even when unplugging the USB cable, the LED remained red.

The only reaction I could get was the phone vibrating when I pressed the power button for about four seconds.

I switched into fastboot (blue LED), ran fastboot reboot and was happy to find the phone actually booting while showing the usual stuff on screen.

After the boot process, suddenly I was asked for the PIN of my SIM card! God knows what happened, but I am now back to having a phone that actually works as a phone.

edit flag offensive delete publish link more

Comments

Jolla, why is the basic functionality, mobile networking, misbehaving so much nowadays? Are only Android and I phones compatible with networks today?

VoPa ( 2019-02-17 13:51:58 +0300 )edit

Thanks so much, I flashed my Xperia XA2 device without a simcard, which is probably the key information here. After successfully flashing and booting the phone, I wasn't able to use GSM services (the SIM card was not recognized). Doing the fastboot reboot made it all work, yay!

cvanca ( 2019-04-05 16:48:47 +0300 )edit

So, this simple command really helps? And it was not because of broken hardware?

VoPa ( 2019-04-15 19:02:27 +0300 )edit
1

answered 2018-11-20 16:32:41 +0300

Spark gravatar image

Out of the blue idea: You could try in that order 1) activating developer mode, 2) install Sailfish Utilities from Jolla Store, 3) go to Settings >> Utilities >> Restart network subsystem.

edit flag offensive delete publish link more

Comments

Even given that we are talking normal cell phone reception (as in calls and texts)?

hammerhead ( 2018-11-21 14:14:43 +0300 )edit
1

answered 2018-11-20 18:10:25 +0300

SaimenSays gravatar image

Maybe a duplicate to "Loss of mobile network" thread, never fixed since beginning of SailfishX.

edit flag offensive delete publish link more

Comments

No. I'm not even getting reception for calls/texts. If only mobile network was affected, that would be ... "great". (Note: The proposed work around mentioned in the linked thread does not do anything for me.)

hammerhead ( 2018-11-21 14:13:14 +0300 )edit
0

answered 2018-11-20 19:12:54 +0300

pawel gravatar image

what says csd ?

edit flag offensive delete publish link more

Comments

What is csd?

hammerhead ( 2018-11-21 14:11:34 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2018-11-20 15:28:10 +0300

Seen: 470 times

Last updated: Feb 15