Ask / Submit
1

xperia x compact recording volume

asked 2018-11-24 19:50:06 +0200

mrtrm gravatar image

updated 2018-11-26 11:00:14 +0200

jiit gravatar image

Recording volume on the xperia x compact is too low. Does anyone know the cli command to change the microphone input for recording? pactl and something I suppose, but I cannot find the right command ... Thx for looking into this,

edit retag flag offensive close delete

Comments

I have an xperia x and there I have no problem with the recording volume. I'm talking about the x compact. Trying to record sax improv ideas, help me remember the good stuff I sometimes play. On the X that worked flawless, on the x compact it is hardly useable ... so not a duplicate ...

mrtrm ( 2018-11-25 09:18:40 +0200 )edit

Typing 'pactl list' or 'pactl --help' makes me hope there is a way to change this, I just don't seem to be able to piece together the right command+options ... Anybody?

mrtrm ( 2018-11-25 09:23:19 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-11-25 21:13:31 +0200

Edz gravatar image

updated 2018-11-25 21:14:51 +0200

Perhaps I should of made myself a bit clearer originally, my bad.

The device in general is not the focus of the problem, the problem is likely in the software that controls the sound card; i.e. mic levels, main volume levels, etc....hence my original comment calling duplicate.

Anyway, I gave this question some more thought and ended up finding a answer I gave on this very subject a few years ago; https://together.jolla.com/question/146486/microphone-volume/

Also, as with many things command line based, there are always a myriad of options/tools to do the same job. The link above shows how to do it with alsa-utils or you can do it with pacmd

I have tested the following on my device this evening; my device is a Jolla1 SFOS 3.0.0.8

MAIN PLAYBACK VOLUME:

Set volume to ZERO
    `pacmd set-sink-volume 1 0` (0%)

Set volume to MAX    
    `pacmd set-sink-volume 1 65536`  (100%) (default)
    ---------------------------------------
    `pacmd set-sink-volume 1 98304`  (150%)
    `pacmd set-sink-volume 1 131072` (200%)
    ---------------------------------------

MAIN RECORDING VOLUME LEVEL

Set MIC INPUT to ZERO;
    `pacmd set-source-volume 2 0` (0%)

Set MIC INPUT to MAX;
    `pacmd set-source-volume 2 65536` (100%) (default)
------------------------------------------------------------------
    `pacmd set-source-volume 2 98304`  (150%)
    `pacmd set-source-volume 2 131072` (200%)
edit flag offensive delete publish link more
0

answered 2018-11-26 00:19:21 +0200

mrtrm gravatar image

@Edz this was exactly what I was looking for, thx! I read the post you mentioned, but with alsa mixer it would not work. pacmd set-source-volume 2 131072 (so doubling 65536) does exactly what I need. I hope it doesn't influence my phonecalls at the other end of the line, will let you know if it does. Thanks for your help!

edit flag offensive delete publish link more

Comments

Good point, at the moment I cannot make calls (no credit) to test mic/call volume/levels.

Edz ( 2018-11-26 01:20:19 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2018-11-24 19:50:06 +0200

Seen: 201 times

Last updated: Nov 26 '18