Ask / Submit
3

Xperia XA2 not detected by fastboot [answered]

asked 2018-11-28 22:17:14 +0200

Squal gravatar image

I have a Xperia XA2 Dual SIM (H4133) and i have tried to install Sailfish OS 3 through a fedora distribution.

I have : - downloaded the package Sailfish_OS-Jolla-3.0.0.8-h4113-0.0.7.10-FIXED.zip. - enable the developer option - enable usd debugging - enable OEM unlocking

I have checked with ##7378423## and the bootloader can be unlocked.

When i hold "volume up" and insert the usb cable, the blue led is correctly seen.

When i enter the command to unlock the phone, it seems that the phone is never recognized:

fastboot -i 0x0fce oem unlock 0xXXXXXXX returns just <waiting any="" device="" for=""> !</waiting>

If i try without -i 0x0fce, i have the same issue.

The phone is detected by the OS:

lsusb

Bus 002 Device 002: ID 174c:55aa ASMedia Technology Inc. Name: ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 004: ID 056a:0013 Wacom Co., Ltd CTE-430 [Graphire3 (4x5)] Bus 001 Device 006: ID 0fce:0dde Sony Ericsson Mobile Communications AB Xperia Mini Pro Bootloader Bus 001 Device 003: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000 Bus 001 Device 005: ID 0a81:0205 Chesen Electronics Corp. PS/2 Keyboard+Mouse Adapter Bus 001 Device 002: ID 045e:074f Microsoft Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can someone help me?

Br, Pascal

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by misc11
close date 2018-11-29 10:09:26.318440

Comments

I had similar troubles, seems to be related to some fastboot versions and USB2 vs USB3 port. Did you try a USB2 and/or using windows?

bomo ( 2018-11-28 22:35:59 +0200 )edit
3

I had a similar issue during the installation with a debian distro. Same issue as you using the exact commands provided on the Linux instructions. My issue was about privileges. I solved it adding sudo first... Good luck!

g ( 2018-11-28 23:31:58 +0200 )edit

YES! Just add sudo solves the problem.

Thank you very much!

Squal ( 2018-11-29 00:08:35 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-11-29 08:01:08 +0200

Will-Do gravatar image

For me this was fixed by adding sudo before the fastboot command (so "sudo fastboot -i 0x0fce oem unlock 0xXXXXXXX")).

edit flag offensive delete publish link more
0

answered 2018-11-28 23:05:06 +0200

LordRooster gravatar image

Usually this is a problem with your USB cable or the USB Port. Try changing both. I had similar problems with my PC. Fastboot should not be installed from your package repository. It is way better to download the android sdk from google. This will give you the latest version. I know that ubuntu/debian provides outdates fastboot and adb versions.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2018-11-28 22:17:14 +0200

Seen: 267 times

Last updated: Nov 29