Ask / Submit
1

use of whisperfish on XA2-ultra (3.0.0.8) - black-screen during calls (in- and outgoing)

asked 2019-01-07 19:32:28 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-01-16 14:31:11 +0200

sutje gravatar image

Hi, anybody, this is my first question here, so please be patient and any advise/tip is very welcome! :) I am using sailfish 3.0.0.8 on XA2-ultra.

When Whisperfish is running, the screen gets inavailable while calling / getting a call. Pressing the power-button to wake up the screen does not work -nor anything else. Pressing Power just leads to a short blink (<1sec) and the display gets black again.

This is very annoying as calls cannot become ended (especially calling a mailbox or check who is calling). Does somebody has an idea on how to solve this issue?

I am very keen to use signal...

Edit_20190108: I am using whisperfish 0.5.1

Got the information that proximity sensor probably is responsible. proximity sensor issues

Edit_20190116: I re-tested and now there is no flickering (on / off of proximity sensor) anymore: the sensor just does not work (=screen always "on"). So my reported test results regarding having whisperfish "on" or "off" seem to be a coincidence: NOW there is no difference whether whisperfish is running or not. Issue is answered and now it is assumed that already reported proximity-sensor-issue is the source here.

edit retag flag offensive close delete

Comments

Yes most likely a dupe and not a problem with Whisperfish. The proximity sensor problems are known and hopefully will be fixed soon.

laubblaeser ( 2019-01-09 20:04:00 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2019-01-09 20:06:46 +0200

laubblaeser gravatar image

updated 2019-01-09 20:07:06 +0200

Not related to whisperfish as the proximity sensor failure happens to all of us.

Quick and dirty workarounds:

  • Whenever your screen turns black during calls and it won't come back on, try a triple press of your power button. That will reset your proximity sensor and you should be able to use the phone again.
  • Otherwise just restart your phone regularly so the proximity sensor gets restarted as well.
  • There's also a tiny little script that you could use to restart the proximity sensor.
edit flag offensive delete publish link more

Comments

1

When whisperfish is not running, there is no issue with the sensor

sutje ( 2019-01-09 20:50:00 +0200 )edit
1

@sutje that would be somewhat strange to me, as I don't know what whisperfish should be doing with the proximity sensor.

bomo ( 2019-01-10 10:24:10 +0200 )edit
1

I re-tested and now there is no flickering (on / off of proximity sensor) anymore: the sensor just does not work (=screen always "on"). So my reported test results regarding having whisperfish on/off seem to be a coincidence: NOW there is no difference whether whisperfish is running or not. Issue is answered and now it is assumed that already reported proximity-sensor-issue is the source here.

sutje ( 2019-01-16 14:29:21 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-01-07 19:32:28 +0200

Seen: 359 times

Last updated: 2 days ago