We have moved to a new Sailfish OS Forum. Please start new discussions there.
15

Sony Xperia XA2 camera issues

asked 2019-01-08 21:31:02 +0300

FS gravatar image

updated 2019-01-09 08:25:54 +0300

raketti gravatar image

Hi,

I'm running Sailfish 3.0.1.11 on my Xperia XA2. The colors of the photos sometimes have a blue tint if I use the flash 20190108_202706.jpg and they are not very accurate.

The autofocus works sometimes not very accurate, too.

Greetings, Frank

edit retag flag offensive close delete

Comments

Hello, I have also observed this problem. It seems to be related to the camera flash. If I disable the flash, I do not have the blue in the picture

MichaelS ( 2019-01-08 21:52:52 +0300 )edit
2

I also suffer from this problem. When you take pictures of humans with flash, they often look veeeeery ill on the pictures and will never allow you to photograph them again ;)

Daniel.T ( 2019-01-08 22:20:59 +0300 )edit

I have same problems. And AWB doesn't work properly and it turns black when i put +2. Especially front camera shows now many tiny little colored dots when I try to take a photo.

Comparing to Android-version camera and video camera are now much worse at the moment.

My device: Sony Xperia XA2, H4113

ari.jarvio ( 2019-03-04 19:28:59 +0300 )edit
1

have an XA2-plus and with 3.0.2 pixels are strong to see with patchwork-like...

cemoi71 ( 2019-03-27 20:45:55 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2019-01-09 20:02:19 +0300

laubblaeser gravatar image

updated 2019-01-09 20:02:41 +0300

I have also experienced this problem.

Whenever I really have to use a flash for my pictures (I try to avoid flash whenever possible), then I simply manually adjust the white balance from "AWB" (automatic white balance) to the "light bulb". This normally fixes the weird colours and lets me take acceptable photos with flash.

However, the camera software needs some reiterations. Especially autofocus and white balance are off in roughly 1/4 of the pictures I take.

edit flag offensive delete publish link more

Comments

It's no wonder that Sailfish camera needs some reiterations

Sakke ( 2019-01-10 08:59:13 +0300 )edit
0

answered 2020-07-08 01:19:22 +0300

cemoi71 gravatar image

updated 2020-07-08 23:58:36 +0300

In my case i noticed that the AWB balance not solve the issue.

I remarked that mostly if i make a photo with flash, the AF use the flash too.
Quite at the start of the AF process, the flash light on 1st with a blue light, which goes in warm white then.
At the end of the AF process the color of the scene on display is quite good.
But the photo is then destroyed with the blue taint, because of the short light on by shooting.

that you can take any type of balance.
The taint goes in blue if you have the iso smaller or = to 800iso.
Especially if contrast is or below 0,5.
And most of the time in combination to the flashlight usage. I don't know what i've done and how, but i had a picture with yellow/green (lemon?) taint.

Seems to me that by AF process and taking photo, a process bring some wrong colors. Is that a compression process? the balance filter?
Duration is too long because the eye is aware of it too.
Maybe there is an other balance correction for the flashlight. And the combination with the UX one, or the cancelling of the UX one is buggy.

I would suggest to the dev team to put the flash light something longer before shooting.
Or combine the AF with shooting if flash light is desired...

What weird is, try to take a photo of a scene which is completely yellow. best case as macro photo. just target of the scene with camera app closed or in background, and open it in front of the scene. Then directly the camera app display the scene with a green lemon taint. taking a photo at this moment let the green taint on the photo. Moving don't change it, until that an other color comes on the scene (then it displays the correct colors).
https://together.jolla.com/question/212974/xa2-photos-appears-green-if-we-have-an-yellow-background/

edit flag offensive delete publish link more

Comments

Err. The XA2 has one flash led. There is no variation in color temperature.

Fuzzillogic ( 2020-07-08 12:30:29 +0300 )edit

I guess he means changing AWB while LED's lit which leads to different colour schemas on the previewed photo and on the taken photo.

Pohli ( 2020-07-08 14:27:46 +0300 )edit

@Fuzzillogic i wanted to prove you what i meant. but by playing with the cam. found that i'm wrong. interesting is, that you can take any typ of balance. the taint goes in blue if you have the iso under smaller/= to 800iso & especially if contrast is or below 0,5. I don't know what i've doen and how, but i had a picture with yellow/green (lemon?) taint. Seems to me that by AF process and taking photo, a process bring some wrong colors. Is that a compression process? the balance filter? Duration is too long because the eye is aware of it too.

cemoi71 ( 2020-07-08 23:38:30 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-01-08 21:31:02 +0300

Seen: 1,504 times

Last updated: Jul 08 '20