Ask / Submit
11

[bug] camera and upgrade page: no sd card inserted

asked 2019-01-09 21:57:45 +0300

cy8aer gravatar image

updated 2019-08-08 09:30:52 +0300

jovirkku gravatar image

In camera app prefs you cannot set sd card. if you re enter the camera app it is set to "no sd card inserted". Found the same in the upgrade app when trying to backup before upgrading to 3.0.1.11.

This is probable a duplicate but did not find it.

edit retag flag offensive close delete

Comments

Same here, with 3.0.1.11. After correction of the setting and quitting the settings app, I could no longer start the settings app again until I rebooted the phone. This may be unrelated, though.

Maus ( 2019-01-09 22:47:50 +0300 )edit

Are you sure that the fotos are not saved to the SD card? The settings page has a bug, but the app itself works correctly once I set the SD card for the first time in the settings app.

wosrediinanatour ( 2019-01-10 14:19:07 +0300 )edit

I had the same problem on updating. I corrected the camera app settings after seeing this issue, but I noticed that it wasn't pointing to the SD-card at first.

Tanghus ( 2019-01-10 14:44:15 +0300 )edit

Check that the memory card is "mounted" in Settings > Storage. An encrypted card does not get automatically mounted after device restart. A non-encrypted card is mounted automatically if it was formatted successfully (or the format is compatible).

jovirkku ( 2019-01-11 11:49:52 +0300 )edit

This is not a duplicate AFAICS, but a duplicate of this question provides screenshots and a more detailed description (although only for the Camera app).

olf ( 2019-02-03 02:44:55 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2019-02-21 15:07:49 +0300

DrYak gravatar image

The "NO card inserted" message can also pop-up if the Camera application doesn't have write-access to the root directory of the card (i.e.: /run/media/nemo/{label of the card}/).

If you've re-formatted the card to a filesystem with POSIX access right (e.g.: reformatted a SDXC from exFAT to ext4), it might still be restricted to the user root.

You'd need to :

  • devel-su chown nemo:nemo /run/media/nemo/{label of the card}
  • chmod 0775 nemo:nemo /run/media/nemo/{label of the card}
edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2019-01-09 21:57:45 +0300

Seen: 218 times

Last updated: Feb 21