JP1: WLAN, BT and mobile connectivity not available

asked 2019-01-14 17:15:51 +0200

Lutwolf gravatar image

updated 2019-01-15 09:53:05 +0200

jiit gravatar image

Hej hej Sailors,

I updated my JP1301 to 3.0.1.11, and everything (except for the not yet updated Patchmanager patches) worked fine. Days later I had to restart my phone (Android making trouble memorywise) which resulted in missing connectivity. I tried mobile network, WLAN and BT, but nothing worked. The CSD tool said everything was fine except network, BT and WLAN all being not available. What can I do to either pinpoint or solve this problem? What might be the reason (other than internal HW damage which of course might also be)?

Cheers!

edit retag flag offensive close delete

Comments

My first aid in such situations devel-su systemctl restart ofono in terminal app Second: reflash SFOS

dirksche ( 2019-01-14 18:33:33 +0200 )edit
1

In with the mix;

devel-su systemctl restart connman.service

or perhaps

devel-su systemctl start connman.service

https://sailfishos.org/wiki/Sailfish_OS_Cheat_Sheet

Edz ( 2019-01-14 18:47:59 +0200 )edit
1

Great documentation. Thank you for this link.

dirksche ( 2019-01-14 19:06:58 +0200 )edit

Nah. journalctl reads "Message recipient disconnected from message bus without replying" as D-Bus request error, net.connman.Clock.SetProperty and modules/radiostates.c: xconnman_set_property_cb()

Also there's "Started Wait for Bluetooth HCI adapter" from multiple sources.

Lutwolf ( 2019-01-15 01:09:20 +0200 )edit