Ask / Submit
1

Sailfish X and CalDav [duplicate]

asked 2019-01-19 14:41:48 +0200

mercurio gravatar image

Goodmorning everyone, I have an Xperia X F5122, with Sailfish X 3 and I have trouble creating an account to link the calendars I have on my server with Netxcloud 15. The main link would be: https: //mydnsservice/nextcloud/remote.php/dav/ and the specific one of the calendar is: https: //mydnsservice/nextcloud/remote.php/dav/calendars/Orestis/prova-1/ I tried in many ways, but I always get the message that it is impossible to create the account and that there are problems. Which ones? Where am I doing wrong? Thanks to those who will help me! :-)

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Tanghus
close date 2019-09-10 00:25:26.915596

Comments

1

Have you already checked it there any hints on the possible problem Nextcloud logs? You can find them via admin acoount and settings.

2kanaa ( 2019-01-19 15:16:43 +0200 )edit

I will try to check, I thank you for the answer! The strange thing is that on an Andorid mobile phone, it works perfectly ...

mercurio ( 2019-01-19 15:25:36 +0200 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2019-01-19 16:08:09 +0200

MrHundert gravatar image

Hello there, i am using a nextcloud + caldav setting for years and what worked for me is to just enter the host url for the server. Also do not enter the url for the calendar, autodetection should work fine. You can then choose which calendars will be synced with your device. Hope it helps :-)

edit flag offensive delete publish link more

Comments

Hello and thanks for the reply! Forgive me but I did not understand: you, when you create the caldav account, enter the user name and password of your Nextcloud and then enter only the address of the server where you have nextcloud for example: https: // yourddnsservice / nextcloud / Did I get it right?

mercurio ( 2019-01-19 16:17:44 +0200 )edit
1

Yes that ist right. Dont even add the "/remote.php"

MrHundert ( 2019-01-19 16:22:27 +0200 )edit

I can confirm this. Autodetection works fine, just provide the server URL and the device password (or your account password if you don't use two-factor auth).
But be warned: after some time synchronization might have hiccups above all CardDAV. That kind of is a known issue with writing new contacts or events failing. I have to readd the account every few months to get it working again

rozgwi ( 2019-01-19 17:38:44 +0200 )edit

I do not know what to say ... I believe that you work ... but I just do not understand why I do not work and on 3 phones with 3 different Android versions, functions perfectly ... If anyone has an idea, I thank him very much! :-)

mercurio ( 2019-01-19 19:25:20 +0200 )edit
1

Maybe looking at the logs could help? There's a section in the Wiki about Card/CalDAV debugging

I should check my assumptions before posting.
Actually my CardDAV URL for Nextcloud looks like this:
https://your.server.domain/remote.php/dav

So autodetection will identfy available adressbooks and calendars but not find the DAV directory by itself. Does this help @mercurio?

rozgwi ( 2019-01-19 20:05:00 +0200 )edit
1

answered 2019-01-19 15:15:40 +0200

pawel gravatar image

updated 2019-01-19 15:30:52 +0200

i am using ocloud, which is basically a owncloud and caldv is working. it took me a while to get it running unfortunatelly sfos does not let me seesthe correct settings of the account.

ok i have tried to recreate it:

the server address has to be:

https://blablabla.ocloud.de (in my case) without https:// it shows your error message

i did not need to define address book nor calendar path, i just left it empty and that was it.

edit flag offensive delete publish link more
1

answered 2019-09-08 18:59:52 +0200

witness gravatar image

I am using ocloud.de with a nextcloud instance and I had the same problem as described by @mercurio with my account. As an other account was created on a jolla1 by typing in the server-url with no problems I started to compare the differences in the phone's configuration. As the only differences were the passwords used I removed the Umlaut "ä" in my password. After the change the account was created immediately. So you might try to "simplify" your password by sorting out special characters one by one. I guess that certain characters are not handeled properly by the caldav-client.

edit flag offensive delete publish link more

Comments

2

@witness: this is worth an immediate bug report. Could you state your version of Sailfish?
@damien Caliste : this might be of interest for you, right?

Unicode really is not the strong suit of Sailfish / Mer libraries (I'm looking at you, C++ with your weird string imbuing concept). CardDAV had issues parsing umlauts in contact fields before.

And in the past Jolla's translation platform wouldn't accept umlauts in passwords.

rozgwi ( 2019-09-08 19:10:01 +0200 )edit

My Sailfish OS version is 3.1.0.11

I don't know if it matters. Hardware: Xperia X, F5121, HW adaption 0.2.1.17 Language: German

witness ( 2019-09-08 20:07:10 +0200 )edit

you mean @damien-caliste

BonoNL ( 2019-09-09 22:39:00 +0200 )edit

mentioning people is very unreliable for users with a space in their handle. Poor damien gets notified half of the time when Damien Caliste is addressed.

another quirk of Askbot...

rozgwi ( 2019-09-10 00:33:15 +0200 )edit
0

answered 2019-09-10 00:25:08 +0200

Tanghus gravatar image

Please, please use the search:

edit flag offensive delete publish link more

Question tools

Follow
7 followers

Stats

Asked: 2019-01-19 14:41:48 +0200

Seen: 796 times

Last updated: Sep 10 '19