Firefox for Android / Fennec versions after 59.0.2 won't run on Jolla Tablet

asked 2019-01-25 12:44:02 +0300

MeegoUser gravatar image

updated 2019-03-28 20:35:03 +0300

As described in the title, Firefox for Android crashes with versions 60.0 and upwards shortly after startup (with a normal Firefox surface visible for a moment) when using the Jolla Tablet, the latest usable release is 59.0.2 from March 2018 (which is between Sailfish versions 2.1.4 and 2.2.0).

In spite of an Alien Dalvik update in September 2018, this issue persists to this day, even though the Jolla Phone with an even older Android layer is executing the latest Firefox versions (66.0.2 at the moment) without any problems. I'm using the "android-api-16" build for both the phone and tablet, the three other available builds either require a newer Android SDK (according to a message during installing) or don't work at all.

This problem is increasingly urgent, since FF extensions are raising their requirements as FF development continues (one important extension already requires version 60+, therefore doesn't get displayed in Mozilla's addon store now for me).

I created a new "logcat" log with Firefox 60.0b17 on Sailfish 3.0.2.8, I've put a gap in the middle where I restart FF after the first crash, without any previous unrelated events/messages beneath:

log.txt

edit retag flag offensive close delete

Comments

I'd like to share log files with possible useful information, if someone gives me a hint where those are stored.

MeegoUser ( 2019-01-25 12:46:18 +0300 )edit

The "logcat" file doesn't cut it, according to File Browser, it hasn't been edited since September '18 and doesn't contain information about the numerous Firefox crashes from today.

MeegoUser ( 2019-01-25 19:57:47 +0300 )edit
1

You need to issue that command, it will fetch the log real-time.

bomo ( 2019-01-25 19:58:48 +0300 )edit

OK, that works, thanks. And how do I export the displayed log into a file?

MeegoUser ( 2019-01-25 21:58:13 +0300 )edit