Ask / Submit
2

Cannot create exchange account on XA2

asked 2019-01-31 22:31:36 +0200

mattikbk gravatar image

I tried to create an exchange account on the new Sailfish X beta on XA2 using the same settings as on my Jolla C, but on the first "Accept" there is a message "Could not create the account" and if I go back and try again, the settings app hangs on "Checking server settings and policies...".

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
3

answered 2019-02-01 00:04:28 +0200

tom-dr gravatar image

updated 2019-02-01 00:16:41 +0200

I had to reboot after installing and setting up my Exchange account.

I got an error with “Provisioning” enabled. Disabled it and could add the account. Then I enabled “Provisioning” again, which gave no error. However, had no email folders (and hence no email) synced. Rebooted the phone and selected Sync under Settings > Accounts > [Exchange account] > [Pull down: Sync] and that got it working.

edit flag offensive delete publish link more

Comments

I managed to create the account with provisioning disabled, but I cannot get the folders to sync

mattikbk ( 2019-02-01 01:04:46 +0200 )edit

Some errors related to sailfish-eas from the journal:

  • [W] unknown:0 - This device does not have a BT adapter
  • 0: handleError: Network error: QNetworkReply::NetworkError(RemoteHostClosedError)
  • 0: FolderSync command failed
mattikbk ( 2019-02-01 01:14:30 +0200 )edit

That worked perfectly! Thanks for sharing :)

ttl1982 ( 2019-02-01 01:48:57 +0200 )edit

@mattikbk the folders initially didn’t sync for me either (I only saw “Drafts” and a few others―no “Inbox”). The reboot and resync resolved that for me. Sorry, didn’t check any logs.

tom-dr ( 2019-02-01 23:03:22 +0200 )edit

For me reboot and resync did not resolve anything. The email app just says "Check configuration" and "Problem with sync"

mattikbk ( 2019-02-02 00:17:31 +0200 )edit
0

answered 2019-01-31 22:56:16 +0200

ttl1982 gravatar image

updated 2019-01-31 23:08:21 +0200

Set sync 'only to device' if you have selected '2 way'. Did the trick for me

Sorry, did not work afterall

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2019-01-31 22:31:36 +0200

Seen: 147 times

Last updated: Feb 01