[bug] aliendalvik memory leak

Tracked by Jolla

asked 2019-02-03 21:18:25 +0200

lethe gravatar image

Aliendalvik sometimes seems to heavily leak memory.

Noticable issues start with "sluggish"/unresponsive UI which gets progressively worse. When the display is off, pressing the power button does not turn on the display but instead the LED starts blinking red.

The last time this happend, htop showed "system_server" using up 25% memory, still increasing.

These issues continue until the phone is rebooted or the kernel's OOM killer kills the right process.

I'm using SfOS 3.0.1.14 with aliendalvik 8.1.0.46.12-1.1.1 on a dual sim XA2 (H4113).

edit retag flag offensive close delete

Comments

Alien Dalvik is completely unusable due to something similar on my XA2 Plus Dual SIM - as soon as I start an app, at first it works, then after 40 seconds to up to a minute it becomes sluggish and freezes, then OOM kills it and Dalvik restarts. Then again.

Watching this in htop is mesmerizing - 3 system-server processes gobble 10% of memory each and take 100% CPU time of one CPU each, until they get killed a while later. Turned out you don't even need to start an app, so that it can get killed. :D

Btw, the old logs folder doesn't work with this Dalvik version, any idea how to get logs out of this?

Bundyo ( 2019-02-04 08:02:33 +0200 )edit
1

This happened to me when I configured the Google Account and syncronyzed the contacts, after I delete my Google account, I didn't had that problem.

carmeloferso ( 2019-02-04 16:02:06 +0200 )edit

You mean in Sailfish, not in the Android runtime, right?

Bundyo ( 2019-02-04 17:05:58 +0200 )edit
1

This is a BIG Issue! Should be PRIO 1 in fixing.. about ~12 hours of running Aliendalvik on XA2 and the System ist completly useless! AD eats more than 98% of memory and OOM Killer did nothing! This must be fixed!

jayki ( 2019-02-04 18:20:23 +0200 )edit
1

I can confirm the issue with android support and google account. Yesterday reseted my XA2 to factory settings, because didn't found other solution. Today was everything fine with andoid support until google account was activated. after removing.google account andoid support worda as designed.

Bratsk ( 2019-02-05 00:07:29 +0200 )edit