Ask / Submit
3

About alarm with XA2... [answered]

asked 2019-02-05 19:23:55 +0200

williamb gravatar image

updated 2019-02-05 19:26:43 +0200

Hello everyone,

Except for not having been able to import my sms in spite of the various topics on this subject, my biggest fault is the following one: When the alarm sounds, the display remains off. It's really very embarrassing to turn it off .... Does anyone have the same problem? or a solution?

(Excuse my approximate english ...)

Williamb

(Sailfish X Beta 3.0.1.14)

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Yo
close date 2019-02-12 22:18:15.247384

Comments

Here everything works well... (SfOS 3.0.1.14, Xperia XA2)

Rafael Flores ( 2019-02-06 00:59:07 +0200 )edit

No problems here (3.0.1.14, XA2). I used the workaround for the proximity sensor... You can find it through the search function

nepomuk ( 2019-02-06 11:31:14 +0200 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2019-02-06 06:26:39 +0200

Kopekenscheich gravatar image

It's the proximity sensor acting up. You need to disable it, then everything will be fine.

edit flag offensive delete publish link more

Comments

Also, snooze via power button works even when display is off -> immediate relief from getting the alarm to stop ringing -> you have five minutes to do something about the p-sensor.

Such as doing a triple power key press to temporarily disable p-sensor (the triple press tracking is done independently from other power key functionality, so invoking it will also snooze the alarm and most likely power up the display too) -> display can be powered up -> start clock app -> disable (and re-enable) alarm so it will not ring again after snooze period is over.

spiiroin ( 2019-02-06 09:28:39 +0200 )edit
1

Thanks a lot ! Since I have switch off proximity sensors, display works fine !

williamb ( 2019-02-07 20:15:08 +0200 )edit
0

answered 2019-02-06 12:25:12 +0200

Kim gravatar image

updated 2019-02-06 12:26:10 +0200

To copy SMS/MMS, copy the folder ~/.local/share/commhistory from the old phone to the new one. Close the message app and remove (or rename) the old folder on the new phone, first.

I did this some days ago, and ended up with all SMS / MMS inclusive the images. I had to add a .nomedia file to commhistory to stop the tracker from adding all the images to my gallery.

WARNING: Any SMS/MMS you have received on the new phone will be lost!

edit flag offensive delete publish link more

Comments

Hello, I did not specify that I come from Android. Your method works only from SOS to SOS, is that correct?

williamb ( 2019-02-06 19:18:40 +0200 )edit

Yes that is correct. I have never used Android so I cannot tell you if it is possible to import sms and mms from there.

Sorry.

Kim ( 2019-02-06 23:40:51 +0200 )edit
0

answered 2019-02-12 22:07:22 +0200

williamb gravatar image

I am trying to answer my own question.

  • About the proximity sensor (thanks to Kopekenscheich):

I disabled it and it works very well, except to hang up a call. The other does it for me in general.

  • About the import of sms:

I used the following method, which stopped on invalid characters (error referred to a " d") In fact, this method does not support emojis. Not knowing the method to convert them, I removed them from the xml using the search function (; & # *;), and it worked. Only MMS, as expected, were not imported. If it helps someone to definitely switch to Sailfish OS ...

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2019-02-05 19:23:55 +0200

Seen: 425 times

Last updated: Feb 12