Ask / Submit
7

Disable pulley menu during call

asked 2019-02-05 23:36:03 +0200

h.berd gravatar image

updated 2019-02-08 23:16:05 +0200

Is there a workaround or patch to disable the hold option during calls? In the worst case I go on 'hold' with my ear and call a other number without knowing it. I have problems with it multiple times in a week and just want to get rid of the pulley menu. Any ideas how to do it?

Thanks!

Edit: Phone is Xperia X with latest SFOS and the proximity sensor is working in general. Its a usability bug.

edit retag flag offensive close delete

Comments

2

Bug?....the screen shouldn't even be on while in a call, is your proximity sensor working correctly?

Edz ( 2019-02-06 00:57:45 +0200 )edit
2

the proximity sensor is working, but I have to hold the phone very straight to my ear all the time - so it's a bug for me ;-). Sometimes I laugh during the call or do other things and then the screen is not locked. Other users have/had the same problem. Simplest thing would be to deactivate this pulley for me. I never use the hold function or call option.

h.berd ( 2019-02-06 01:09:31 +0200 )edit
2

I'm suffering this same, Sailfish X on Xperia X. usually no prob when me calling, no "on hold". but incoming calls for some stupid reason really easy go to "on hold" because pulley meny becomes active suddenly during phone on ear.

peakki ( 2019-02-06 08:17:02 +0200 )edit
1

There are at least three topics about the hold bug here. Many are dicussed like only the proximity sensor is the cause, but in my opinion the pulley is a bad idea in general. I don't know how much work a patch would need, but it would be great for many users to deactivate the pulley. Other option would be that jolla intrgrates it in the config menu, but then we probably have to wait years till this is done.

h.berd ( 2019-02-06 10:27:07 +0200 )edit
1

I agree that there is not much of a point to the pulley menu on the call screen, but this is still a problem with the proximity sensor. Perhaps there is a strange bug that reactivates it when it shouldn't be activated. If it were working correctly, the screen wouldn't turn on. Unless you're pressing the power button to turn on the screen, but I doubt that.

nthn ( 2019-02-06 12:29:01 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2019-02-07 02:13:58 +0200

didilalala gravatar image

Trick that is maybe not a answer but try to hit the power key right before before bringing it to your ear , it just turn off the display ( does not lock the phone) and it won't turn back on if the prox sensor is cleared . You have to eiter double tap or hit the power key again to turn the display back on and then end the call.

edit flag offensive delete publish link more

Comments

thanks I will test this

h.berd ( 2019-02-07 12:10:11 +0200 )edit
3

answered 2019-02-08 14:52:58 +0200

Levone1 gravatar image

updated 2019-02-08 23:13:47 +0200

h.berd gravatar image

New patch ...

image description

(not mine - just reporting)

Edit (h.berd):

Yes, thats the patch that @Edz provided on openrepos because of my question here. This is the link to openrepos

See our comments in the first question for more background info, if you are interested.

@All: Please send @Edz a little Tip, if you like this patch. For me today was the first day where I could answer a call without thinking about how to hold my phone straight to my ear ;-) Many thanks again for this fast fix! :-)

edit flag offensive delete publish link more

Comments

thanks for Markkyboy, works good with Xperia X!

peakki ( 2019-02-08 21:26:21 +0200 )edit
2

Cool, thanks for donation @h.berd and kind words - enjoy! :)

Edz ( 2019-02-08 23:19:08 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-02-05 23:36:03 +0200

Seen: 423 times

Last updated: Feb 08