Ask / Submit
0

Bluetooth Audio with Xperia X and VW RCD 310

asked 2019-02-17 13:06:14 +0300

tokaru gravatar image

Has anyone been successful in using bluetooth audio with Xperia X with a Volkswagen RCD 310 radio?

While coupling the phone, browsing the contact list etc. works fine, I have not been able to get BT audio up and running. As far as I have read, the radio should display the "BT Audio" media source when a device supporting A2DP is connected. Some sources say that media playback must be running on the device for the system to recognize it. Did not work for me. I noticed the Xperia did not ask whether to allow access to audio features when I coupled it with my car. (It did that when I coupled the Xperia with another phone.)

SailfishOS officially supports A2DP 1.2 - in TJC I found different threads where users report success and failure of using BT features in different cars. So is this a known issue? Is there a trick/workaround for this, e.g. by fiddling in the terminal?

Thanks in advance.

edit retag flag offensive close delete

Comments

hello! i have rcd 310, but dont have xperia x to test it out. would you like to give one for me for charity? thanks!

coderus ( 2019-02-18 00:25:11 +0300 )edit

@coderus unfortunately, I don't have a spare one ;-)

tokaru ( 2019-03-02 16:50:03 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-02-17 15:00:11 +0300

tokaru gravatar image

After some more trial and error, I got audio playback working now. This time, I have started media playback before (re-)coupling the device, and then it worked. SailfishOS still did not ask me whether to allow acess to audio features. (So maybe intermediately coupling the Xperia to another mobile device and granting access was also part of the solution.)

Unfortunately, what still does not work (and should, according to SailfishOS's and VW's spec) is AVRCP, i.e. controlling media playback from the car.

edit flag offensive delete publish link more

Comments

I have the RCD 310 too, but without Bluetooth build in, but with the VW Media-In socket. I connected the Tune2Air Bluetooth dongle to Media-In, and audio works, but track informations don't (but that's problem of the dongle, track information works only with iOS, not with Windows 10 Mobile, Android or Sailfish). Can't test it right now, but as far as I remember I could use media controls (skip track and so on), but just when I use Jollas Media Player. If I use Unplayer the controls don't work. But that's just said from my mind, I'll give it another test.

Cryx ( 2019-02-18 09:37:06 +0300 )edit

Thanks for your feedback. Even with direct BT connection, there is no track information displayed for me on my Sailfish device, haven't tried with Android. THanks for pointing me to uplayer, looks nice, will check it out :)

tokaru ( 2019-03-02 16:55:30 +0300 )edit

Tried with unplayer today, it is exactly the same: audio playback works, but no track information and no controls.

tokaru ( 2019-03-03 17:03:48 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-02-17 13:06:14 +0300

Seen: 141 times

Last updated: Feb 17