Ask / Submit
0

XA2 play services not working [duplicate]

asked 2019-02-18 11:15:57 +0300

pkuronen gravatar image

updated 2019-02-19 13:36:51 +0300

Play services not working in XA2 beta. Cannot use most of the applications due to this. Hopefully will be functional in full version of Android support.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Sakke
close date 2019-02-18 22:32:37.870664

Comments

2

Maybe this should be stated more clearly on the Jolla website: Sailfish is not a flavor of Android. And "Android apps support" does not (and will never) include the Google part. There are certainly bugs in the - still beta - aliendalvik implementation but missing Google Play Services are not one of them.

You could do some things with microG. But if Google services etc. are essential to you, I am afraid you will have to use Android.

femtopeta ( 2019-02-18 14:03:07 +0300 )edit

Play services work in Xperia X but are not officially supported. There seems to be no problem in that. Android is there to give broader selection of applications that are not available native so please do not drop compatibility with play services. Especially if it takes just some directory structure or other simple modification.

pkuronen ( 2019-02-19 07:59:51 +0300 )edit
1

@Sakke when you are closing for duplicate reason it would be nice to link to that one even if you refer to my link as duplicate (it is abou the same topic but named completely different, nobody will find that searching for 'play services'). Or also rename the linked question?

peterleinchen ( 2019-02-19 13:38:04 +0300 )edit
1

@peterleinchen, Yeah I understand your point. To begin with, I hesitated with the closing procedure since I wasn't sure whether it was about irrelevant question etc. since this topic has been stated on Jolla's official relase as it's mentioned in one of the answers. There was also good links to other contributions on the issue so I thought it was obvious enough without any particular links / information. Feel free to contribute to this, it's not absolute close procedure here. But as far as I've understood and the way I see this, the case is closed. Could there be a better title for closing?

Sakke ( 2019-02-19 14:23:08 +0300 )edit
1

understood/accepted/no discussion...

I re-tagged this one here and the 'duplicate' there https://together.jolla.com/question/198500/xperia-xa2-sailfish-x-dont-have-systempriv-app-directory/

peterleinchen ( 2019-02-19 14:30:00 +0300 )edit

2 Answers

Sort by » oldest newest most voted
6

answered 2019-02-18 11:52:01 +0300

santhoshmanikandan gravatar image

updated 2019-02-18 14:42:07 +0300

It has been already stated that Play Services will not work in XA2

Google Play services are not supported; therefore certain apps may not function properly.

https://together.jolla.com/question/198359/release-notes-sailfish-x-beta-30114/

There is a way to install the MicroG services in XA2. But it doesn't fully rectify the problem

https://www.youtube.com/watch?v=1K05m3EJJ9A

edit flag offensive delete publish link more

Comments

1

It can still be made compatible with play services.

pkuronen ( 2019-02-19 07:53:10 +0300 )edit
2

answered 2019-02-18 12:40:02 +0300

updated 2019-02-18 13:22:50 +0300

And this may be a show stopper for few people who need GMS for 'apps' requring this. And no info if it may be supported in future or not. But according to the past I guess official support will never come (licensing issue).

Nevertheless there are already efforts to get around:

https://together.jolla.com/question/198500/xperia-xa2-sailfish-x-dont-have-systempriv-app-directory/

edit flag offensive delete publish link more

Comments

It's hard to say, but Android smartphones are cheap and for about 100 € to buy. We are here at Sailfish OS and not at Google? This should be known and considered before buying SFOS. Nothing is kept secret.

You are right, official support will never come.

4carlos ( 2019-02-19 06:30:39 +0300 )edit

Did not check it yet but if for example e-banking software requires play services then it is a show stopper for most professional users. If it takes simple modification to make play services work in SFOSX then I see no reason not not to do that.

Let's rephrase this: make SFOSX play services compatible. No need to support it officially.

pkuronen ( 2019-02-19 07:51:24 +0300 )edit

Maybe yes, but e-banking with play store or Gapps are show stoppers in my eyes.

Again, SFOS is not Android. Sorry, wrong device.

4carlos ( 2019-02-19 08:27:29 +0300 )edit
6

That is why there is a freedom of choice to stay with the community edition and a paid one with closed source inclusion of Android applications. You are free not to purchase commercial Android support and stay with community only version. Please no ideology discussions here as I am only asking broader support for already existing feature - which is not forced to anyone.

pkuronen ( 2019-02-19 12:30:25 +0300 )edit

Question tools

Follow
4 followers

Stats

Asked: 2019-02-18 11:15:57 +0300

Seen: 1,395 times

Last updated: Feb 18 '19