Ask / Submit
3

"Could not load page"

asked 2019-03-14 12:23:29 +0200

Edz gravatar image

updated 2019-03-14 19:09:06 +0200

I have 2 x Jolla1 devices and both are exhibiting the same problem. In Settings/Developer tools/WLAN IP address, tap on the lan ip address and a page opens with the message "Could not load page".

Is any one else seeing the same thing . if not, what is on that page and how to get it back?

NOTE - it looks like a category/topic has undergone a name change, in this case from 'networking' to 'wlan' or perhaps just a copy and paste error, either way.

The problem affects other devices; Xperia X and Xperia XA2 as noted by @Veyah & @Kim respectively.

edit retag flag offensive close delete

Comments

2

I get the same message on Xperia XA2 with.

Kim ( 2019-03-14 12:26:21 +0200 )edit

same on my Xperia X with 3.0.1.11

Veyah ( 2019-03-14 12:32:14 +0200 )edit
1

what do you expect to be loaded from that page? that supposed to display your wlan IP address, it might be a bug trying to open it as a link from there?

pmelas ( 2019-03-14 12:53:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2019-03-14 15:22:26 +0200

Edz gravatar image

I believe I've answered my own question with a hint from pmelas

looks like a copy/paste error or perhaps devs just forgot to make the change.

The file that causes the error "Could not load page" is due to an incorrect Url found in;

devel-su nano +514 /usr/share/jolla-settings/pages/developermode/developermode.qml @ line 514

currently:

            NetworkAddressField {
                icon: 'image://theme/icon-m-wlan'
                //% "WLAN IP address"
                caption: qsTrId("settings_developermode-la-wlan_ip_address")
                text: developerModeSettings.wlanIpAddress
                readOnly: true

                onClicked: pageStack.animatorPush(Qt.resolvedUrl('../networking/mainpage.qml')) // /networking - wrong topic

                visible: root.showDeveloperModeSettings
            }

should be:

            NetworkAddressField {
                icon: 'image://theme/icon-m-wlan'
                //% "WLAN IP address"
                caption: qsTrId("settings_developermode-la-wlan_ip_address")
                text: developerModeSettings.wlanIpAddress
                readOnly: true

                onClicked: pageStack.animatorPush(Qt.resolvedUrl('../wlan/mainpage.qml')) // /wlan - correct topic, I think!

                visible: root.showDeveloperModeSettings
            }

With the edit made above, I can now directly access the WLAN page normally found in Settings/WLAN

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2019-03-14 12:23:29 +0200

Seen: 142 times

Last updated: Mar 14