Ask / Submit
3

[Bug] [3.0.2.8] Newly installed apps do not appear in menu [answered]

Tracked by Jolla

asked 2019-03-19 16:29:59 +0300

Bundyo gravatar image

updated 2019-04-24 00:31:23 +0300

After upgrading XA2 Plus to 3.0.2.8, newly installed Android apps fail to create shortcuts in the menu. The *.desktop files are still copied in the /usr/share/applications folder.

EDIT: As per the comments below, seems this is happening only on the XA2 Plus for some reason.

Check my answer below for the fix for my issue. Still, aliendalvik install shouldn't fail silently in this case and somehow warn the user.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by olf
close date 2019-04-24 20:17:04.836912

Comments

Is this on the XA2? Could you list the contents of one of the desktop files that isn't appearing?

Andy Branson ( 2019-03-19 18:32:16 +0300 )edit

try with Jolla C, not confirmed

sashikknox ( 2019-03-19 19:37:11 +0300 )edit

Sorry, should have mentioned that it is in XA2 (Plus if this matters). I've tried installing several apps through the Yalp store, two of them I installed before and they added shortcuts with no icons - Instagram was one of them.

Bundyo ( 2019-03-19 21:19:17 +0300 )edit

Cannot reproduce on my XA2, could it be specific to XA2 Plus?

kkarioja ( 2019-03-19 21:46:10 +0300 )edit

Will be very strange if it is. More likely a problem in my TV.

Bundyo ( 2019-03-19 22:00:09 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-04-23 10:47:39 +0300

jlaakkonen gravatar image

As a workaround to the problem when applications installed via Aptoide are not shown in appgrid on Sony Xperia XA2 (tested on H4113):

NOTE: this workaround applies only when there are files in /usr/share/apkd/partnerspace/ blocking normal operation.

  1. Enable developer mode, open terminal and run following in terminal as root (devel-su).
  2. Remove partnerspace files: rm /usr/share/apkd/partnerspace/* (add -f after rm to not to prompt for every file)
  3. Remove apkd created desktop files: rm /usr/share/applications/apkd_launcher_* (add -f after rm to not to prompt for every file)
  4. Restart apkd: systemctl restart apkd - this should bring the icons to appgrid.
  5. Restart alien dalvik, Settings -> Android Support in UI or with systemctl restart aliendalvik
edit flag offensive delete publish link more
1

answered 2019-04-23 21:10:20 +0300

Bundyo gravatar image

updated 2019-04-23 21:10:47 +0300

Looks like the new version of Aliendalvik failed silently to install on my device because my /opt partition was too full. I did some modifications to system.img and made a backup that I forgot to delete, which was the prime reason, as pointed by balta here:

http://talk.maemo.org/showthread.php?p=1556260#post1556260

Check your /opt partition since it is only 820MB and do a manual version --dup to install what is left (make sure ssu re is 3.0.2.8 or it will downgrade instead).

All icons appeared after the upgrade to 46.17.

edit flag offensive delete publish link more

Comments

So this issue can be closed now?

olf ( 2019-04-23 23:41:57 +0300 )edit

Yeah, seems so, at least for me.

Bundyo ( 2019-04-24 00:27:50 +0300 )edit

I guess I should wait for the other two guys to confirm it is fixed?

Bundyo ( 2019-04-24 00:44:18 +0300 )edit
0

answered 2019-04-23 21:17:40 +0300

TrulloF gravatar image

I had similar problems on my X Compact (3.0.2.8) with newly installed Android apps not showing on desktop, but they were remedied by uninstalling AlienDalvikControl. Now installation and shortcuts are working. Maybe it's worth a try, if you're using ADControl from openrepos too.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2019-03-19 16:29:59 +0300

Seen: 424 times

Last updated: Apr 24