Ask / Submit
43

SMS does not work after installing 3.0.2.8

Tracked by Jolla

asked 2019-03-23 19:48:31 +0300

uppiksenkaveri gravatar image

updated 2019-05-17 02:33:14 +0300

carmenfdezb gravatar image

I can't send and receive SMS after installing 3.0.2.8 Oulanka. I don't even find the app in Jolla Shop / in my installed apps.

Tried the eSMS, doesn't work either. I have also installed Textra from Store, also not funktioning. But I don't understand why the original Jolla SMS app is not any more available in Jolla Shop and doesn't show in my own apps in Jolla Shop

25.3.2019 I was today at my teleoperator and explained the situation. They tried everything and gave me a new SIM-card, which didn't help. So it is definitely a bug, why my mobile phone doesn't work after installing Oulanka 3.0.2.8

26.3.2019 I am not going to reset to Factory settings, because it takes too much time to uppgrade everything afterwards. Now I can't even uppgrade my Telegram and Whatsapp. It says, that something didn't function. My MeeCast doesn't show the locations any more.

27.3.2019 After I tried everything, I did reset to factory settings. But that didn't work either. When the mobile phone opened again, it had still Oulanka 3.0.2.8. installed. I still have problems, have to reboot again and again. It works a while and when it doesn't, I have to reboot again. I guess, that I just have to wait for the next uppgrade.

edit retag flag offensive close delete

Comments

Just a question: Where did you got the update? i've been looking for software update and for new image on sailfish store but nothing. My xperia xa2 don't show any update.

Celso ( 2019-03-23 21:47:07 +0300 )edit
1

Does sending SMS from within cSMS work?

It's designed to send/receive encrypted SMS but can handle unencrypted SMS as well.

spag ( 2019-03-23 21:56:44 +0300 )edit
2

@Celso The update is only early access yet. You have to activate it in your Jolla account (website) if you want to receive it until it goes public.

Spark ( 2019-03-23 22:44:41 +0300 )edit
1

I forgot to mention: you can find cSMS in the Jolla Store

spag ( 2019-03-24 00:18:43 +0300 )edit
5

It might be worth running

devel-su
pkcon refresh
version --dup
sync
reboot

in case that some packages were not installed in the upgrade.

Manatus ( 2019-03-24 11:55:18 +0300 )edit

10 Answers

Sort by » oldest newest most voted
6

answered 2019-04-08 23:14:46 +0300

Andre gravatar image

I had the same problem on an Jolla1 and JollaC (converted Aquafish). SIMs in both phones are in roaming currently. I tried the following in order without success:

  • shutdown + start
  • switch 4G->2G
  • tried iptables -I INPUT -j ACCEPT; ip6tables -I INPUT -j ACCEPT
  • tried pkcon refresh && ssu --dup && reboot
  • tried devmode off && reboot
  • tried 2G->3G && reboot
  • tried devmode on && reboot
  • tried 3G->4G
  • swapped sims

I did install cSMS which worked for sending but not receiving SMS.

I did restart ofono as root (systemctl restart ofono). At that point sending and receiving SMS worked again but the sender was wrong and got replaced by the recipients message center number. (both phone were showing "si unknown" or similar incorrect information for the whole time sims were swapped)

After swapping the sims back the Jolla1 (with ThreeUK sim) continued to work and had the correct sender information when sending SMS. The JollaC (with simquadrat sim) failed to send/receive SMS again and a simple ofono restart didn't help. Switching to 2G only then restarting ofono made SMS send/receive work on the JollaC again but with incorrect sender details (switching back to default prefer 4G broke it again but using sim slot 2 works with prefer 4G but incorrect sender still). I'll see if that changes when not roaming.

It feels like something (ofono?) fails to read the SIMs correctly and then uses whatever it remembers.

Example log from ofono (Jolla1) below:

[root@Sailfish nemo]# journalctl -b | grep -i ofono
Apr 08 21:11:39 Sailfish ofonod[1056]: oFono version 1.21
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Novatel modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Sierra modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding ZTE modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Icera modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Huawei modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Calypso modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding MBM modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Telit modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding HSO modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Infineon modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding STE modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Dialup modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Hands-Free Profile Driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding SpeedUp modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Phone Simulator driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding CDMA AT modem driver
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding External Hands-Free Profile Plugin
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Dial-up Networking Profile Plugins
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding BlueZ 5 Utils Plugin
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding Hands-Free Audio Gateway Profile Plugins
Apr 08 21:11:39 Sailfish ofonod[1056]: Excluding CDMA provisioning Plugin
Apr 08 21:13:28 Sailfish ofonod[1056]: RIL version 7
Apr 08 21:13:28 Sailfish ofonod[1056]: SIM card OK
Apr 08 21:13:28 Sailfish ofonod[1056]: Requested file structure differs from SIM: 6fb7
Apr 08 21:13:28 Sailfish ofonod[1056]: pin retry query is not supported
Apr 08 21:13:34 Sailfish statefs[695]: Qt5 loader: loading /usr/lib/statefs/libprovider-ofono.so
Apr 08 21:13:34 Sailfish statefs[695]: Establish connection with ofono
Apr 08 21:13:34 Sailfish statefs[695]: Ofono: sim is present
Apr 08 21:14:18 Sailfish dbus[713]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.12" (uid=0 pid=1056 comm="/usr/sbin/ofonod -n --nobacktrace --noplugin=he910") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1093 comm="/usr/bin/fastdormancyd ")
Apr 08 21:15:12 Sailfish ofonod[1056]: SMS History Probe for modem: 0x127eea0
Apr 08 21:15:12 Sailfish ofonod[1056]: Registered interface org.ofono.NetworkTime, path /ril_0
Apr 08 21:15:12 Sailfish ofonod[1056]: nw select automatic
Apr 08 21:15:12 Sailfish tart[1667]: [D] unknown:0 - (dial) GetAll() failed: "org.freedesktop.DBus.Error.UnknownObject" "Method \"GetAll\" with signature \"\" on interface \"org.sailfishos.ofono.mdm.VoiceCallFilter\" doesn't exist\n"
Apr 08 21:15:12 Sailfish tart[1667]: [D] unknown:0 - (incoming) GetAll() failed: "org.freedesktop.DBus.Error.UnknownObject" "Method \"GetAll\" with signature \"\" on interface \"org.sailfishos.ofono.mdm.VoiceCallFilter\" doesn't exist\n"
Apr 08 21:15:12 Sailfish statefs[695]: Ofono status  "searching"
Apr 08 21:16:00 Sailfish ofonod[1056]: Requested file structure differs from SIM: 6fb7
Apr 08 21:16:00 Sailfish statefs[695]: Ofono status  "roaming"
Apr 08 21:16:00 Sailfish dbus[713]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.12" (uid=0 pid=1056 comm="/usr/sbin/ofonod -n --nobacktrace --noplugin=he910") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1093 comm="/usr/bin/fastdormancyd ")
Apr 08 21:16:01 Sailfish ofonod[1056]: read_info_cb: 6f3a not found
Apr 08 21:16:01 Sailfish ofonod[1056]: read_info_cb: 6f4a not found
Apr 08 21:16:01 Sailfish ofonod[1056]: read_info_cb: no phonebook on SIM
Apr 08 21:16:01 Sailfish ofonod[1056]: export_entries_one_storage_cb with SM failed
Apr 08 21:16:01 Sailfish ofonod[1056]: export_entries_one_storage_cb with ME failed
Apr 08 21:16:03 Sailfish ofonod[1056]: data reg changed 2 -> 5 (roaming), attached 1
Apr 08 21:16:15 Sailfish statefs[695]: Ofono status  "searching"
Apr 08 21:16:15 Sailfish ofonod[1056]: data reg changed 5 -> 0 (unregistered), attached 0
Apr 08 21:16:16 Sailfish statefs[695]: Ofono status  "roaming"
Apr 08 21:16:16 Sailfish ofonod[1056]: data reg changed 0 -> 5 (roaming), attached 1
Apr 08 21:18:56 Sailfish dbus[713]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.12" (uid=0 pid=1056 comm="/usr/sbin/ofonod -n --nobacktrace --noplugin=he910") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1093 comm="/usr/bin/fastdormancyd ")
Apr 08 21:22:39 Sailfish dbus[713]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.12" (uid=0 pid=1056 comm="/usr/sbin/ofonod -n --nobacktrace --noplugin=he910") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1093 comm="/usr/bin/fastdormancyd ")
edit flag offensive delete publish link more
5

answered 2019-05-05 22:07:53 +0300

broncheolus gravatar image

Hi there,

I also have problems with sending and receiving SMS. I have a Jolla1 with 3.0.2 installed. I can not exactly tell when this problem started, that's because I do not receive a lot of SMS. I realised the problem when I missed an apointment. It seems to be quite similar to the problem mensioned here. I tried all the stuff mensioned above, sometimes it helped but right now nothing helps. I could not find a red line how to reactivate SMS functionality.

Another interesting thing is that after reboot my phone needs about 2-minutes to connect to my provider again. Then sometimes it connects, disconnects for some seconds and reconnects again. Then the connection is stable. Data work well, I also can phone but no SMS.

I am thinking about activating developer release to have a chance to use SMS again because putting my SIM-card into my old NOKIA to use "netbanking" with TAC-SMS is quite a pain. (On my nokia SMS works flawlessly)

I dont think that someone can help me here (allthough I hope), I just wanted to point out that there seems to be a real SMS or connection problem with 3.0.2.

Greetings, broncheolus.

edit flag offensive delete publish link more

Comments

2

My Jolla 1 is exactly behaving the same way. In the beginning when this problem started it helped to shutdown the phone, take aout the battery for a few minutes and than start it again. But once I had to restart ofono and from that point on the above described method did not work anymore to make SMS working again.

Just out of interest I tried the following procedure: enable flight mode, restart the phone and disable flight mode once the phone is fully started again. Since then my Jolla 1 can receive and send SMS again.

I also have set my mobile network to "3G prefered", because with "4G prefered" I can not receive MMS.

Stefan P ( 2019-05-06 00:45:12 +0300 )edit
1

Dear Stefan P.,

I installed early access but nothing changed concerning the SMS problem. But your hint activating flight mode then rebooting and then deactivating flight mode again really did the trick. You found the right combination of activating, deactivating, rebooting and changing forth and back the right switch.

!!!!!Man, you really made my day!!!!! You are my hero!!

It even works with 4G (I don't have MMS service with my provider to check your problem, sorry) So let's hope that this is no bug but just something that's got mixed up and is fixed now for good.

Should one make a bug report to Jolla concerning this problem?

broncheolus ( 2019-05-06 13:50:52 +0300 )edit

I can confirm "enable flight mode, reboot, disable flight mode" works. It doesn't do anything to the underlying problem though. If I do a normal reboot the phone, more often than not, comes up with faulty sms.

unbob ( 2019-05-06 18:37:53 +0300 )edit

@ broncheolus Good to hear that this procedure worked on your phone as well. I really hope that Jolla will solve this problem, because it is really annoying when you don't know if you can receive SMS or not at the moment. I have even already startet to send my self a SMS from time to time to check if my phone is still able to receive SMS.

At least the thread is tracked by Jolla, so let's hope that this really means that they take the issue serious.

Stefan P ( 2019-05-06 23:04:31 +0300 )edit

I've got an update concerning my SMS problem. I was able to reproduce this issue by installing the 3.0.3.9 release. After install SMS was broken again. Procedure mensioned above (activate flight mode - reboot - deactivate flight mode) worked again like a charm. What did not change is the fact that connecting to network after reboot takes a really long time more than 3'-4'. (maby the underlying problem mensioned above?) With prior to 3.0.2 connection was established when GUI was ready.

I hope this helps you tracking down the problem. Greetings from Austria, broncheolus.

broncheolus ( 2019-05-07 22:11:11 +0300 )edit
4

answered 2019-03-26 22:21:04 +0300

mips_tux gravatar image

updated 2019-03-26 22:22:00 +0300

Incredible a such bug ! This afternoon i reboot my phone because it lost gsm network. My J1 did not reboot correctly and it stays on red light. So i take off the battery. My j1 reboot. But without SMS. So i just rebooted my J1 and SMS comes back !!!

Can you try a reboot of your smartphone ? May be it's the solution. I hope (and sorry for my poor english)

edit flag offensive delete publish link more

Comments

1

Rebootin didn't help. It was the first thing I tried

uppiksenkaveri ( 2019-03-26 22:51:52 +0300 )edit
1

I had rebooted several times to no avail, but this time I rebooted by taking my battery out and putting it back, and it looks like SMS are back! Thanks mips_tux!

The process of refreshing the installed packages as suggested by Manatus did not seem to solve the problem. Taking out the battery did. Yay for removable batteries!

belluzj ( 2019-03-26 23:02:39 +0300 )edit

Did you tried the terminal thing from @Manatus?

It should help.

What network and phone are you on?

BonoNL ( 2019-03-26 23:12:11 +0300 )edit
1

My GSM Network is Free (France). When i reboot my phone this afternoon, the network was down and did not came back again. It's for this reason that i reboot it. So may be, put your phone on airplane mode and reboot it ? Then, after the reboot, disable the airplane mode and try again to send sms ? At this time, after a travel by the metro where the network is very bad, my SMS is always "on".

mips_tux ( 2019-03-27 00:29:01 +0300 )edit
1

for me it helped to enable the developer mode. it seems that something missing was installed with it. after disabling sms are still working.

donni106 ( 2019-03-27 03:29:53 +0300 )edit
4

answered 2019-03-27 11:35:44 +0300

Sebix gravatar image

updated 2019-06-17 15:16:05 +0300

As neither rebooting nor the instructions of Manatus helped, I did a backup, factory reset and all updates until 3.0.0.8. This works, but it is a pain.

Afterwards I upgraded to 3.0.2 again - and messaging still did not work. So it is reproducible.

EDIT: Same problem behavior in version 3.0.3.10

edit flag offensive delete publish link more

Comments

3

Please @Jolla : track this critical bug !!!!

mips_tux ( 2019-03-27 12:24:00 +0300 )edit

Hi. I´ve got a question... XPERIA X.... Don´t understand if this SMS issue is a general issue or if it happens to "some" (but nevertheless too many) people only.. Therefore I`m unsure whether or not to update. - May I therefore please ask... Is there someone out there who did the update on an XPERIA X and noow does not face SMS issues, please? - Many thanks.

MaTi ( 2019-03-28 12:22:20 +0300 )edit

Just FYI: Just gave it a try and updated my XPERIA X to 3.0.2.8 - At least at the moment ....and from the beginning.... SMS is working fine.

MaTi ( 2019-03-28 15:45:14 +0300 )edit

At this time, our Intex (as Jolla C) now updated to 3.0.2.8 has not this issue with SMS.

mips_tux ( 2019-04-02 10:29:04 +0300 )edit

my Xperia X is also working fine after upgrade to 3.0.2.8 - the only issue I had was with "Prefer 4G" and no network. After going to "Prefer 3G" all works fine.

deloptes ( 2019-04-03 17:42:02 +0300 )edit
4

answered 2019-05-09 15:56:06 +0300

updated 2019-05-15 12:21:53 +0300

I had the same issue after upgrading my Xperia X to SFOS 3.0.3.9. I am not sure if the issue already was there on 3.0.2.8 as I am not receiving SMS that often. At least I received an SMS on April 28th with 3.0.2.8. Now with 3.0.3.9 I had to receive SMS from eBay 2FA an I never received it. I then also tried to send SMS but that did not work, too.

I tried the solution from broncheolus, but it didn't seem to help despite several attempts.

What seemed to resolve the issue for me (at least for now) was to reenter the mobile number of the SMS central:

  1. Open SMS/Messages settings in Settings -> Apps
  2. The first input field should show the mobile phone number of the SMS message central
  3. Remember the number and change the last digit
  4. Swipe back to app settings overview and open the messages settings again
  5. Now set the last digit back to the original one
  6. Optionally restart your phone

That worked for me and I now can send and receive SMS. As I tried the solution from broncheolus at first I am not sure what helped really…

Another thing I discovered in the systemd journal when receiving a SMS is the following log line:

ofonod[716]: SMS acknowledgement failed: Further SMS reception is not guaranteed

Update from 2019-05-15

I now had the issue again and tried broncheolus' solution again. It is for now the only solution for me that fixes the issue for some time.

edit flag offensive delete publish link more
4

answered 2019-06-07 06:05:56 +0300

covox gravatar image

I started getting issues on my Jolla 1 with Hossa (3.0.3.9 and 3.0.3.10):

  • initially after the reboot, SMSes would fail to send and offer the retry button, even if there was a phone network connection (e.g. calls would work)
  • mobile data sometimes refuses to bind, creating a mountain of errors in the Ofono log
  • activating and deactivating Flight Mode leaves the phone network connection dead, with no apparent retries showing in the Ofono log, until the next reboot

I found this explanation buried in one of the zendesk pages, but you can manually reset the Ofono state, which worked (for me to at least) get full mobile connectivity back after the update. It's probably equivalent to Stefan P's workaround.

  • Enable developer mode
  • Open a terminal
  • devel-su
  • systemctl stop ofono
  • cd /var/lib/ofono
  • rm -rf *
  • reboot
edit flag offensive delete publish link more
3

answered 2019-05-21 16:42:14 +0300

Phragmites gravatar image

I see this problem on Intex Aqua Fish converted to Jolla C and updated to Sailfish OS 3.0.3.9. Every time I start the phone, sending SMS doesn't work.

Solution: turn on airplane mode, reboot, turn off airplane mode. Any other action in the above posts did not work for me.

This is ridiculous. Single question: Why is all this necessary?

edit flag offensive delete publish link more

Comments

Your solution works/worked for me, too!

Peeder ( 2019-06-04 22:22:05 +0300 )edit
2

answered 2019-03-30 02:17:38 +0300

pagurus gravatar image

For me, disabling developer and then re-enabling developer mode fixed it.

edit flag offensive delete publish link more

Comments

Can you check the mobile network - what you have as preferred network there?

I had the experience totally loosing the network after the upgrade https://together.jolla.com/question/202778/prefer-4g-and-no-network-after-upgrade-to-3028/

Did someone try going to 3G or 2G?

deloptes ( 2019-03-30 02:24:27 +0300 )edit

Fiddling with the mobile network, e.g. change to 3G and back to 4G together with disabling/enabling the developer mode and a reboot has helped.

Vieno ( 2019-04-01 23:03:46 +0300 )edit

So, which one helped exactly?

deloptes ( 2019-04-02 01:09:50 +0300 )edit

@deloptes: Not to sure. Connecting to a mobile network takes quite often different time. After reboot I could connect. Maybe it would have worked without, if I would have waited a bit longer.

Vieno ( 2019-04-03 15:52:19 +0300 )edit

For me I its not possible anymore to re-enabling the developer mode. Has anybody the same result? SMS fixed not yet. Edit: Now, I set the release again to 3.0.2.8 because "ss s" show the old version 3.0.1.14 https://together.jolla.com/question/203167/developer-mode-can-not-be-activated-after-deactivation-in-3028/ Which version get you back with:

ss s
chris_bavaria ( 2019-04-03 20:18:53 +0300 )edit
2

answered 2019-04-26 03:54:23 +0300

GD gravatar image

Similar. XA2+ Dual Sim (H4493)

Base Config of device.

  • Primary SIM using MVNO (Virtual operator)
  • Second sim inserted but disabled. Also a MVNO (For testing as such not yet activated with provider)
  • 128GB microSD (Ext4) Camera set to save to SD
  • Interesting point When enable second sim SMS and Calls set to Second sim, would default to First sim once disabled. (Was using second sim as primary before. Again testing various setups.)

Could not send SMS But could recieve SMS and MMS

Tried the following with No Success.

  • Restart device (Multiple Times)
  • Confirm SMS message centre address (Was correct)
  • Disable SIM Pin
  • Re-enable second sim and set calls and sms to first sim.

What worked for me.

  • Remove second sim. I can once again send.

I'm hoping to be able to use second sim, but for now I'll leave it empty. (Did have another issue with 2 sims from the same MVNO But that's for another question.)

edit flag offensive delete publish link more

Comments

Same on my phone (XA2+DS H4493) :

  • Slot 2: empty and is currently disabled
  • SMS doesn't work
  • Turning the empty slot on
  • SMS functionality is restored.
  • Turning the empty slot back off
  • Now SMS remain functional
DrYak ( 2019-04-30 21:23:12 +0300 )edit
0

answered 2019-04-21 20:11:10 +0300

Artemys gravatar image

may this thing be related with that I cannot send mms while roaming? it says that my mobile data settings prevent this. i tried reboot more times, even changed some mms sending settings, but did not help. (maybe i should run a pkcon refresh as someone wrote above, but earlier this killed my phone and led to blank homescreen so i had to reinstall Oulanka manually, so i do not really dare to do it again...)

edit flag offensive delete publish link more

Comments

Allow roaming in mobile network settings.

addydon ( 2019-04-21 20:38:12 +0300 )edit

surprise! it is enabled.

Artemys ( 2019-04-21 20:58:24 +0300 )edit
Login/Signup to Answer

Question tools

Follow
16 followers

Stats

Asked: 2019-03-23 19:48:31 +0300

Seen: 2,646 times

Last updated: Jun 17