Ask / Submit
9

Bug: bluetooth audio not connected

asked 2014-01-27 20:06:34 +0200

Jlillia gravatar image

updated 2014-01-27 20:07:13 +0200

Every time I try to use any of my bluetooth devices for audio (listening music in car or with headset) I have to do following; turn bt-device on -> music comes frome phones speakers. After I Restart bt-device so the connection is established again -> sound comes right through Bt-device. Doesn't matter if music is actually playing or not. In any case audio won't be directed to external device at first connection.

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-21 18:07:02 +0200

c.la gravatar image

updated 2014-03-21 18:07:42 +0200

if you long press on the BT device -> change settings you then have the option to set the device to automatically connect

edit flag offensive delete publish link more

Comments

I tried to find this in earlier software versions but for some reason I was unable to find this option. With current version (Ohijärvi) this worked.

Jlillia ( 2014-04-02 19:25:04 +0200 )edit

glad to hear that. Can you please close the question as answered?

thank you

c.la ( 2014-04-03 13:49:09 +0200 )edit
0

answered 2014-03-20 10:28:09 +0200

the_mgt gravatar image

updated 2014-03-21 14:43:29 +0200

I was irritated by this behavior, too. Especially when I connected a handsfree set in the car for the first time. I somehow expect instant connection after pairing.

There seems to be a method which is more hassle free: In Settings -> System -> Bluetooth, turn on bluetooth and then single-tap on the device you want to use (if it is turned on/read for connection, of course). There should appear some small text underneath the device name, reading "Audio connection established" or something like that. Works with my BT speaker in the kitchen and the handsfree set.

EDIT: Ok, there seems to be an issue with the service the BT device wants to connect to your mobile. Only on the second time the connection between device and Jolla is established will there be a dialogue which asks me wether I want to allow deviceX to connect serviceY to my phone. HFP in case of the handsfree set, etc. Then I can check a button "Allow device to always connect." This whole shebang should happen on the first connection and presto -> sound!

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-01-27 20:06:34 +0200

Seen: 463 times

Last updated: Mar 21 '14