Flashlight doesn't always turn on

asked 2019-03-27 09:16:49 +0300

MRI-xa2 gravatar image

updated 2019-05-02 01:57:33 +0300

I have experienced many times that flashlight doesn't turn on. Sometimes it works.

The icon shows text "Päällä" (On), but there is no light. If I try to tap the icon again I get notification "Meneillään" (On-going), but nothing happens.

The device is Sony Xperia XA2 Single SIM. I have Advanced Camera application installed.

Maybe it is related to another issue that sometimes I can't use camera from Android applications, there is Android notification which requests reboot of the phone. Maybe some other camera application is reserving the camera and flashlight somehow?

Anyone else experiencing the same issue?

edit retag flag offensive close delete

Comments

Yep, noticed the same. The Flashlight gets stuck and the Camera doesn't open if so. There's no relation to the advanced camera app, I had this issue on the 3.0.1 release as well (didn't remember to report it though).

raketti ( 2019-03-27 10:53:23 +0300 )edit

The flashlight can't be always switched on on 3.0.3.8 either.

MRI-xa2 ( 2019-05-02 02:00:40 +0300 )edit

Can you use the camera still? I need to reboot if the flashlight gets stuck. All camera apps crash on launch if the flashlight is stuck.

raketti ( 2019-05-02 06:59:00 +0300 )edit

No. The camera get stuck as well. It doesn't recover without a reboot.

MRI-xa2 ( 2019-05-02 11:03:39 +0300 )edit

Need to test the camera and launch it from the command line, I found an old issue related to the camera: https://together.jolla.com/question/168403/bug-camera-crashes-on-startup/

No mention about if it's related to the flashlight or not, worth investigating though as it seems that this is not a wide problem so might be a small number of devices that's affected by a faulty package installation.

raketti ( 2019-05-02 12:30:52 +0300 )edit