Ask / Submit
14

[HowTo] Flash v17B vendor binaries over v16 on Xperia XA2 Plus without touch sfos installation

asked 2019-03-29 17:22:38 +0300

as400 gravatar image

updated 2019-03-29 20:26:15 +0300

rgp gravatar image

I flashed v17B binaries over an installed v16 and everything is fine. So if you feel like it just do it:

fastboot -s your_device_id flash oem_a SW_binaries_for_Xperia_Android_8.1.6.4_r1_v17_nile.img

You can find your_device_id by doing:

fastboot devices

Sailfish seems intact. All data is in place and apps working. Happy flashing :)

I don't take any responsibility for bricked phones !!!

Note: Reports of experiences are here welcome. :-)

edit retag flag offensive close delete

Comments

see https://together.jolla.com/question/202575/xa2-vendor-bin-16-or-17b/ for existing discussion/request for feedback

bomo ( 2019-03-29 17:50:52 +0300 )edit

@bomo i think that is not a duplicate. it explain explicitly how to upgrade the binary without to flash all....

cemoi71 ( 2019-03-29 19:12:14 +0300 )edit

@cemoi71, this info is also already linked in the other thread. I am just saying that its more convenient to have all info in a single thread :-)

bomo ( 2019-03-29 19:13:51 +0300 )edit
1

correct but the explicit info is missed in your linked thread.

cemoi71 ( 2019-03-29 19:16:36 +0300 )edit

and even if, in comment is not well highlighted to be found promptly... do you see what i mean?

cemoi71 ( 2019-03-29 19:20:44 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-03-30 00:10:26 +0300

Chris_ gravatar image

updated 2019-03-30 14:21:12 +0300

The best solution is to use vendor id where all xa2 have the same id.

fastboot -i 0x0fce flash oem_a ...img

edit flag offensive delete publish link more

Comments

3

fastboot flash oem_a ...17B.img did it for me - no ID, no -s option, no nothing.

Kopekenscheich ( 2019-03-30 14:51:24 +0300 )edit

fastboot devices, doesn't work for me.

How can I find out which one is installed? Thanks for the answers, sailors!

rosapold ( 2019-03-30 20:39:16 +0300 )edit

@rosapold with which os did you make the job? if ubuntu, try with sudo, with other linux maybe with root or admin user. no idea with windows & mac

cemoi71 ( 2019-04-01 23:40:04 +0300 )edit

don't know if 0x0fce option is correct. before forcing something, all possibilities should be used. if something is wrong with host computer or device, possibility to break something by flash ing is higher...

cemoi71 ( 2019-04-01 23:44:32 +0300 )edit

I did the upgrade to version 17B, I think.

Until now, everything runs as expected, Wifi+, 4G, battery drain with WIFI, Bluetooth sometimes becomes autistic, dalvik, the battery that heats, etc...

Is there a way to know which version of the Sony image is installed?

manu007 ( 2019-04-06 20:03:42 +0300 )edit
5

answered 2019-03-29 20:06:56 +0300

as400 gravatar image

I'm sorry if i offended any rules here. I just wanted to share my experiences.

edit flag offensive delete publish link more

Comments

2

its all good. you did everything right! thanks for shareing! :)

misc11 ( 2019-03-29 20:59:07 +0300 )edit
1

yop nothing wrong the most important is done. sharing.
Rest is just simple matter of form

cemoi71 ( 2019-03-29 23:40:45 +0300 )edit

You did wonderfull, no need to excuse yourself :)

Dylan Van Assche ( 2019-03-31 10:21:45 +0300 )edit
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2019-03-29 17:22:38 +0300

Seen: 608 times

Last updated: Mar 30