Ask / Submit
1

[XA2] Opera night mode displays warning every time [answered]

asked 2019-04-01 15:29:04 +0300

Direc gravatar image

updated 2019-04-01 15:29:53 +0300

I noticed this in 3.0.1, but it doesn't seem to be reported yet, so doing it now.

When I enable Night Mode in Opera, Sailfish OS pops up a notification that Opera is drawing on top of other apps (in practice I think it's because of the button bar). This is fine, but every time I minimize opera and reactivate it, the same notification appears again. It soon gets very frustrating, as there doesn't seem to be a way to disable the message in Android settings, which can be accessed by tapping the notification.

I'm running Sony Xperia XA2 Ultra with SFOS 3.0.2 and v17B.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Direc
close date 2019-04-16 18:38:45.561592

Comments

1

Similar thing for signal on XA2: It always keeps on telling me "Signal is using battery" since I turned off battery optimization for signal.

bomo ( 2019-04-01 16:45:45 +0300 )edit

I'm pretty sure this type of notifications is unhideable on Android, so it would make sense that as soon as you remove it on Sailfish and reopen the/an Android application, the underlying Android infrastructure notices the unhideable notification has disappeared and recreates it. I don't know if there's a way to forcefully hide these notifications on Android, let alone on Sailfish, but either way I don't think it's technically a bug.

nthn ( 2019-04-01 19:32:59 +0300 )edit
1

@nthn then it's a bug in android :D

bomo ( 2019-04-01 19:34:14 +0300 )edit

Well, there should be a per app setting for it.

Sailfish OS shows the notification, and it gets removed by itself when minimize the browser. It gets created anew on reactivation, and there's no way of stopping it.

My Xperia X running Android doesn't do this, so it looks like a bug to me.

Direc ( 2019-04-01 20:51:44 +0300 )edit

If I disable the permission, and enable night mode, the permission is requested and handled correctly, but it still tells it to me every time.

Direc ( 2019-04-01 20:53:59 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-04-16 18:38:26 +0300

Direc gravatar image

As @leszek pointed out, the solution - abeit not that logical - can be found in another question: https://together.jolla.com/question/201906/bugxperia-xa2302alien-dalvikandroid-notifications-bother-with-constant-power-consumption/

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2019-04-01 15:29:04 +0300

Seen: 296 times

Last updated: Apr 16