Ask / Submit
6

Change default reminder in Calendar

asked 2019-04-20 13:48:04 +0300

tonio gravatar image

updated 2019-04-23 10:20:54 +0300

jiit gravatar image

In Sailfish 3 the default reminder of a new event is "never". This is very annoying for me, considering that I use it mainly as a reminder. How can I modify the default setting?

Thanks

edit retag flag offensive close delete

Comments

This is right. Previously it was set to the latest one selected. This behaviour is the worst possible: if you want to set a default, set it to the time of the event, or important reminders could go unnoticed.

Giacomo Di Giacomo ( 2019-04-20 15:15:03 +0300 )edit

so, no need to edit anything @Giacomo Di Giacomo ?

Edz ( 2019-04-20 15:27:05 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-04-20 16:08:03 +0300

atlochowski gravatar image

it will be fixed in 3.0.3.x

edit flag offensive delete publish link more

Comments

What does 'will be fixex' means? Will it get selectable? +1 Or just again 'last.used.value'? -1

peterleinchen ( 2019-04-20 21:50:16 +0300 )edit

it means it will be like before. It will remember last choice.

atlochowski ( 2019-04-20 23:22:49 +0300 )edit
0

answered 2019-04-20 14:48:39 +0300

Edz gravatar image

@tonio

What would you prefer to have as a default setting?

If you want to edit this setting, then using terminal, go to this file;

line 325 /usr/share/jolla-calendar/pages/EventEditPage.qml

                //% "Remind me"
                label: qsTrId("calendar-add-remind_me")
                menu: ContextMenu {
                    // TOP LINE NOW AT THE BOTTOM OF THE LIST
                    ReminderMenuItem {
                        seconds: 0 // ReminderTime
                    }
                    ReminderMenuItem {
                        seconds: 5 * 60 // Reminder5Min
                    }
                    ReminderMenuItem {
                        seconds: 15 * 60 // Reminder15Min
                    }
                    ReminderMenuItem {
                        seconds: 30 * 60 // Reminder30Min
                    }
                    ReminderMenuItem {
                        seconds: 60 * 60 // Reminder1Hour
                    }
                    ReminderMenuItem {
                        seconds: 2 * 60 * 60 // Reminder2Hour
                    }
                    ReminderMenuItem {
                        seconds: 24 * 60 * 60 // Reminder1Day
                    }
                    ReminderMenuItem {
                        seconds: 2 * 24 * 60 * 60 // Reminder2Day
                    }
                    ReminderMenuItem {
                        seconds: -1 // ReminderNone // TOP LINE NOW HERE
                    }
                }

IF you change the order of the items on the list, they are presented the same way in the app. For example, I took the top line, removed it and placed it at the bottom. now when I look at the actual 'Remind me' page, I see 'Never' is at the bottom of the page, but as expected, The 'Remind me' menu default now shows "At the time of event" as default.

As ever, pics paint a thousand words...

image description image description

edit flag offensive delete publish link more

Comments

It works!

Thanks a lot

tonio ( 2019-04-20 15:54:18 +0300 )edit

@tonio

Hmm, on reflection, yes it works but I think I realise now it is not necessary to edit the file.

The comment made by Giacomo Di Giacomo suggests that when you select "at time of event" once, it will always be the default setting each time you create a new event. I did not realise this was default behaviour.

Without editing the said file and then playing about with calendar, I realise that its current behaviour is correct as it is, as suggested by Giacomo Di Giacomo

Edz ( 2019-04-20 18:15:21 +0300 )edit

@Edz I cannot confirm that once 'at time if event' is selected it gets the default. The next new event has again 'never'

peterleinchen ( 2019-04-20 20:04:39 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-04-20 13:48:04 +0300

Seen: 146 times

Last updated: Apr 20