Ask / Submit
1

PiVPN configuration not directly usable in SFOS OpenVPN GUI [answered]

asked 2019-04-23 23:39:57 +0300

dirksche gravatar image

updated 2019-04-24 10:00:27 +0300

Maus gravatar image

Hi. I just installed an vpn server on my Raspberrypi (named pivpn). If I try to connect via SFOS it does not work. It toggles between: connecting and problems with connecting. If I try the same with SecureFishNet from openrepos everything works fine. What I realised: protocolltype of server is udp. protocolltype of Sailfish Client is TCP. (I can not change, only to "standard"). Do you have any idea? Another question: if I'm connected via SecureFishNet is every single connection (browser, messenger etc) tunneld?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by dirksche
close date 2019-04-25 20:13:28.039464

1 Answer

Sort by » oldest newest most voted
1

answered 2019-04-24 09:19:01 +0300

Maus gravatar image

I recommend to write a basic configuration file for your service, and to import that into the Sailfish GUI, if you have to use that GUI. By defining all necessary variables (like proto udp), there's not much the GUI can do wrong any more. On the other hand, there are lots of caveats here, too; e.g. the GUI is unable to cope with passphrase protected key files. But anyway, you're better off with a decent configuration file than with going fully through the GUI.

edit flag offensive delete publish link more

Comments

"I recommend to write a basic configuration file for your service, and to import that into the Sailfish GUI, if you have to use that GUI."

That is exactly what I did. In SecureFishNet I have to add the Key Password. I couldnt find a similar entry possibility in the GUI.

dirksche ( 2019-04-24 09:38:52 +0300 )edit

@dirksche Why does it then use TCP as connection protocol? As I wrote, OpenVPN Jolla style does not allow keys to be protected by a passphrase (yet). But this is the first time I read that a proto udp is not honored by the client.

But I have to admit that I have never used that GUI myself, so I should probably just remove this answer if it is of no help.

I just remembered that there is another PiVPN related question on TJC that contains information on how to remove the passphrase from the key to make it usable in Jolla's CLI. If it's only this that breaks your configuration, this question may be a dupe.

Maus ( 2019-04-24 09:55:35 +0300 )edit

Thank you @Maus for this information. I have no idea why the GUI always try to use TCP. I will try to erase the passphrase, otherwise I will use SerureFishNet.

dirksche ( 2019-04-24 10:12:15 +0300 )edit
1

Hi, are you saying that Settings > VPN > Add new VPN > OpenVPN > Skip > Advanced > Protocol Type has options: Default, UDP and TCP, doesn't work for you?

Does the /var/lib/connman/provider*/settings file contain right OpenVPN.Proto information?

Sage ( 2019-04-25 08:46:36 +0300 )edit

Since SecureFishNet works like a charm I don't care about the native VPN solution. And if, like Maus mentioned, the Gui can't handle passphrase protected key files, it is obsolet for me. But thanks for your comment.

dirksche ( 2019-04-25 20:06:25 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2019-04-23 23:39:57 +0300

Seen: 155 times

Last updated: Apr 24