Ask / Submit
1

[BUG]Bluetooth consumes too much power

asked 2019-04-24 02:43:25 +0300

xbt123ufo gravatar image

updated 2019-05-04 02:30:52 +0300

After I use Bluetooth and turn it off, the power consumption is very high. After one night, the power consumption is 20%, but when I have not used Bluetooth, I only consume 4% overnight.

edit retag flag offensive close delete

Comments

1

Maybe you want to try the new EA 3.0.3.8 where the wifi problem is supposed to be fixed.

bomo ( 2019-04-25 10:33:06 +0300 )edit

Bluetooth and wifi adapters share the same frequency bandwidth, and thus are tightly interconnected under the hood. Perhaps just having Bluetooth enabled triggered the bug. Just a thought...

Direc ( 2019-04-26 16:34:14 +0300 )edit

After I upgraded to 3.0 3.8, I found that the problem still exists.Just last night, almost 40% of electricity was consumed in one night.

xbt123ufo ( 2019-04-27 01:26:45 +0300 )edit

Does anyone have the same problem?

xbt123ufo ( 2019-04-27 01:33:17 +0300 )edit

I'm using bluetooth all the time, for my Pebble watch icw Rockpool. I haven't noticed problems with it. However, the WLAN drain was much higher, to the point that I disabled wifi and used mobile data only for many weeks. I got up to three days of battery life. Now, on 3.0.3.8, wifi power drain should be fixed, so I've enabled it again, but I get much less time out of one charge so it seems.

To me, bluetooth seems fine, but wifi is still an issue. Guess I'll try to disable wifi again and see what happens.

Fuzzillogic ( 2019-04-27 03:18:22 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-05-01 08:18:32 +0300

ghling gravatar image

I'm not sure if I'm facing the same issue, but it's possible. Usually, I have Bluetooth enabled on my Xperia X to sync with my smartwatch. Since the latest update (3.0.3.8) I'm experiencing an increadibly high power consumption (Standby time with a full battery dropped from around 30 hours to 9). Until now, I suspected the sync daemon application (Amazfish) to be the culprit, since it is not updated to the libicu update and I had to sideload the old library. Closing the App and disabling Bluetooth seems to have reduced impact on battery, but it is still far worse then previously. I will monitor the situation further. Ruling out the sync daemon is only possible after it has been updated to the new SFOS Version.

edit flag offensive delete publish link more

Comments

In my impression, the previous power consumption seems to be that when I turn off the Bluetooth, the button to turn on the Bluetooth in the settings will be stuck and cannot be turned on. In the last few times, when there is no such situation, the power consumption is normal after one night.I guess it might be related to this.

xbt123ufo ( 2019-05-01 08:41:37 +0300 )edit
1

answered 2019-05-07 12:26:14 +0300

manu007 gravatar image

updated 2019-05-08 11:38:50 +0300

I did a little study of battery consumption (XA2 Plus, H4493):
3.0.2.8 - V17B:
BT-ON, WIFI-OFF = 2.5% / hour
3.0.3 - V17B:
BT-ON, WIFI-ON = 3.5% / hour
3.0.3 - V16:
BT-OFF, WIFI-ON: 1.7% / hour
BT-ON, WIFI-ON: 2.5% / hour
(edit) Flight mode: 0,65% / hour

For my side, I consider that the consumption of the battery is almost normal.

edit flag offensive delete publish link more

Comments

BT/WIFI on means on and connected to something or only on?

bomo ( 2019-05-07 13:13:17 +0300 )edit

wifi can be connected or not, normally 90% of the time. BT on but disconected 90% of the time, normally the BT consumes more being disconnected than connected.

manu007 ( 2019-05-08 12:10:54 +0300 )edit
0

answered 2019-05-04 02:21:40 +0300

xbt123ufo gravatar image

Now I make sure that when Bluetooth is stuck, the power consumption will become very high. After last night, the power consumption reached 20%.

edit flag offensive delete publish link more

Comments

on my xperia-x, if I disconnect by doing a short press on the device, the device (bt stereo speaker) changes status to not connected, as expected, but one cpu core goes to 100%. this core stays at 100% also if I now disable bt by settings main bt switch. I consider this a bug. if I instead of the short press to disconnect the device, instead go directly to disable bt by the bt settings main switch, there will be no 100% drain by any.core. how do you turn off bt on your xa2? rgds

spectorr ( 2019-05-08 18:14:55 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2019-04-24 02:43:25 +0300

Seen: 580 times

Last updated: May 08