Ask / Submit
7

Screen is turning off randomly [3.0.3.8] [BUG] [duplicate]

asked 2019-04-26 10:56:06 +0300

atlochowski gravatar image

updated 2019-05-05 22:32:08 +0300

Screen is turning off randomly. Sometimes when I scrolling app grid screen is turning off. Then I have to double tap to wake it up. I don't have logs for it yet but I will try to provide it. It's happening to me on Jolla 1 but I'll try to reproduce it on Jolla C.

I'm not sure but I think it can be connected with this http://talk.maemo.org/showpost.php?p=1556375&postcount=22

EDIT

Now I know it's not randomly. When I open menu from the lock screen (quick access to camera is turned off) screen turning off after 10s. It doesn't matter if I'm scrolling the screen or not it turns off after 10s.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by atlochowski
close date 2019-05-06 11:14:32.785848

Comments

running hossa here on XA2 Plus and i experience the same thing... although once i disabled the android support from starting it seems the effect is gone.

__rob__ ( 2019-04-27 12:44:28 +0300 )edit

I guess this is due to aliendalvik constantly crashing. I see the same behavior since I uninstalled aliendalvik control from openrepos. Although I don't use any Android app aliendalvik starts, crashes, starts, crashes. This also comes with extra battery drain. When aliendalvik crashes it always blanks the display (it's still touch sensitive in this state!). When pushing the power button, the display flashes shortly. When pushing the power button again, the phone can be used (but is locked). Do you see the same?

Yo ( 2019-05-01 20:02:46 +0300 )edit

I can confirm the behaviour Yo is seeing. Each time the android support crashes the display is dimmed... and since I memorised the location of the brightness slider, I can pull from the edge and tweak (up or down) the brightness and then the display comes back to life.

I am still trying to figure out why is the Android Support crashing so much on a clean installation of 3.0.2.8 with the upgrade to 3.0.3.8 and trying to install only one app from Jolla Store 'Here WeGo maps' (nothing else installed, neither native nor Android)

__rob__ ( 2019-05-02 19:37:31 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-06 10:49:02 +0300

spiiroin gravatar image

updated 2019-05-06 10:55:50 +0300

The original report looks like dup of: https://together.jolla.com/question/204034/screen-turns-off-after-few-seconds-while-in-app-list-opened-from-lock-screen/

Regarding the comments referring to aliendalvik: That is a known separate bug for which a fix is underway.

EDIT:

And that TMO discussion: Device getting locked in background while watching video/navigating/otherwise having display on without interacting with the device is "as designed", i.e. not a bug.

edit flag offensive delete publish link more

Comments

sorry for duplicate

atlochowski ( 2019-05-06 11:14:19 +0300 )edit

Thanks very much, @spiiroin

Its great to see someone from jolla answering!

Yo ( 2019-05-06 12:34:57 +0300 )edit

Question tools

Follow
5 followers

Stats

Asked: 2019-04-26 10:56:06 +0300

Seen: 363 times

Last updated: May 06