(some?) special characters in phone numbers mess up SMS messages [bug] [] [XA2]

asked 2019-04-26 13:20:50 +0300

Yo gravatar image

Hi there!

Since forever I store telephone numbers in the format +49.123.12345678 with a dot separating country code from area code and phone number. It worked fine all these years on all devices including my Palm 3x (sending the phone number via IR to my Nokia Phone), my Palm Treo 680, Nokia N900, and Sailfish OS - until now.

After installing sending SMS to such numbers fails immediately ("problem when sending the message").

Also the list of conversations is now filled with numbers instead of names because it seems the messages app no longer can match the numbers to the contacts.

If it makes any difference: My contacts are synced via CardDAV.

What's happening here? Why is there a change all of a sudden? Any ideas?

On the other hand: Receiving receipt reports finally works!

edit retag flag offensive close delete


Same issue here. Contacts in carddav no special characters, i was able to send one sms and not again... with + 10MB update after the Hossa one. XA2 Plus DualSIM

__rob__ ( 2019-04-29 17:41:53 +0300 )edit

I ended up exporting all contacts to vcf, replace all dots by dashes, delete all contacts and then import the changed vcf file. It worked...

Yo ( 2019-04-29 22:58:42 +0300 )edit

I've switched my SIM card to a different operator and all the rest stayed the same and SMS seems to work (¯\_(ツ)_/¯)

__rob__ ( 2019-05-02 19:40:36 +0300 )edit