Ask / Submit
1

native apps won't start

asked 2019-04-30 08:06:07 +0300

pawel gravatar image

updated 2019-04-30 08:06:27 +0300

since last Update it happened that gallery would not start, another day keepass. a reboot always fixed that

edit retag flag offensive close delete

Comments

In my experience, the Gallery app starts OK some time after a reboot. I suspect that the tracker is indexing files on every restart and the app does not gracefully handle this situation.

Maus ( 2019-04-30 09:46:59 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-01 12:27:18 +0300

dyraig gravatar image

I frequently encounter that with a number of applications, and have been experiencing that in various versions of SailfishOS (I'm currently still on 3.0.1.x). In all cases, opening a terminal and issuing the command

killall NAME_OF_PROGRAM

solves the problem without a reboot. It seems that in some cases, programs do not start up properly and it looks as if they have not started at all, but in the background, some process nonetheless gets started and blocks any further attempts. By killing that, the program works again. Of course, this is only a workaround and not a solution for the actual cause of this issue.

edit flag offensive delete publish link more

Comments

will check next time

pawel ( 2019-05-01 17:12:54 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-04-30 08:06:07 +0300

Seen: 202 times

Last updated: May 01