Ask / Submit
0

Answered: my supplemental apps versioning confusion [no downgraded apps with 3.0.3.9 (Hossa) compared to 3.0.2.8 (Oulanka)] [answered]

asked 2019-05-08 23:37:18 +0300

Sunny gravatar image

updated 2019-05-09 09:24:37 +0300

I'm really wondering why almost all jolla (store) apps were downgraded version-wise, besides sailfish-office (almost consistently, only translations has a smaller version on Hossa than on Oulanka) Here's the diffs on my Xperia X, both flashed Hossa resp. Oulanka from scratch (out of the box, no modifications):

calligra-components         3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-data               3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-filters            3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-kf5                3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-libs               3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-plugins            3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-sheets-core        3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-stage-core         3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
calligra-words-core         3.1.0+git1-1.4.2 < 3.1.0+git4-1.6.1
sailfish-office             1.4.3-1.11.4     < 1.4.4-1.12.1
sailfish-office-all-translations-pack   0.6.1-1.6.3 **>** 0.6.1-1.6.2

jolla-email also has some upgraded dependencies, but also downgraded:

buteo-sync-plugins-email            0.1.1-1.4.4    **>** 0.1.1-1.4.1
jolla-email                         0.4.14-1.13.3      < 0.5.1-1.15.1
jolla-email-all-translations-pack   0.6.1-1.6.6    **>** 0.6.1-1.6.3
jolla-email-settings                0.4.14-1.13.3      **>** 0.5.1-1.15.1
jolla-settings-accounts-extensions-email 0.3.51.1-1.13.5   **>** 0.3.53-1.13.4
libqmfmessageserver1-qt5            4.0.4+git108-1.8.8 < 4.0.4+git111-1.10.1
nemo-qml-plugin-email-qt5           0.4.10-1.12.3      < 0.5.1-1.13.1
qmf-notifications-plugin            0.2.0-1.3.3    **>** 0.2.0-1.3.1
qmf-notifications-plugin-all-translations-pack 0.6.1-1.6.4 **>** 0.6.1-1.6.1

jolla-mediaplayer:

grilo-plugin-tracker            0.2.17-1.2.7    < 0.2.17-1.3.1
grilo-qt5                       0.1.13-1.4.3    **>** 0.1.13-1.4.1
grilo-qt5-qml-plugin            0.1.13-1.4.3    **>** 0.1.13-1.4.1
jolla-mediaplayer               1.0.1-1.10.4    < 1.0.2-1.11.1
jolla-mediaplayer-all-translations-pack 0.6.1-1.6.3 **>** 0.6.1-1.6.2
libgrilo                        0.2.15-1.2.3    < 0.2.15-1.3.1
libjollamediaplayer             1.0.1-1.10.4    < 1.0.2-1.11.1

aliendalvik:

aliendalvik             1.0.89-1    = 1.0.89-1
apkd                    0.8.7-1.7.6 **>** 0.8.7-1.7.4
apkd-android-settings   0.8.7-1.7.6 **>** 0.8.7-1.7.4
apkd-config-home        0.8.7-1.7.6 **>** 0.8.7-1.7.4
libqapk             0.4.11-1.4.4    **>** 0.4.11-1.4.1
quazip                  0.5.1-1.3.4 **>** 0.5.1-1.3.1

jolla-calculator:

jolla-calculator                        1.0.0-1.5.3 **>** 1.0.0-1.5.1
jolla-calculator-all-translations-pack  0.6.1-1.6.4 **>** 0.6.1-1.6.1

jolla-calendar:

jolla-calendar                          0.8.10-1.13.4   < 0.8.10.2-1.14.2
jolla-calendar-all-translations-pack    0.6.1-1.6.5 **>** 0.6.1-1.6.2
nemo-qml-plugin-calendar-qt5            0.4.5-1.9.4 **>** 0.4.5-1.9.1
nemo-qml-plugin-calendar-qt5-lightweight 0.4.5-1.9.4 **>** 0.4.5-1.9.1
sailfish-components-calendar-qt5        0.8.10-1.13.4   < 0.8.10.2-1.14.2

jolla-developer-mode:

fingerterm                  1.3.7-1.3.3         <   1.3.8-1.4.1
gdb-gdbserver               7.6.2+git4-1.3.1    <   7.6.2+git5-1.3.5
jolla-developer-mode        0.5.10-1.7.6     **>** 0.5.10-1.7.1
jolla-developer-mode-profile    0.5.10-1.7.6  **>** 0.5.10-1.7.1
openssh-server              7.7p1+git4-1.5.1    <   7.9p1+git2-1.5.2
qmllive                     1.0.0+git5-1.4.4  **>** 1.0.0+git5-1.4.1
qmllive-sailfish                0.3.0-1.3.4   **>** 0.3.0-1.3.1
qt5-qtdeclarative-plugin-qmlinspector   5.6.3+git5-1.4.3 < 5.6.3+git7-1.5.1
rescue-password-off             0.4-1.2.4    **>** 0.4-1.2.1
rsync                       3.1.0+git2-1.4.5 **>** 3.1.0+git2-1.4.1
screen                      4.0.2+git2-1.4.6 **>** 4.0.2+git2-1.4.1
sdk-deploy-rpm                  1.1-1.3.3    **>** 1.1-1.3.1
vim-minimal                 7.3.629-1.2.1       <   7.3.629-1.2.4

jolla-notes:

jolla-notes                         0.9.14-1.8.3  **>** 0.9.14-1.8.1
jolla-notes-all-translations-pack   0.6.1-1.6.3   **>** 0.6.1-1.6.1
jolla-notes-settings                0.9.14-1.8.3  **>** 0.9.14-1.8.1
sqlite                              3.13.0+git2-1.4.2 ? 3.13.0+git3-1.3.6

sailfish-eas:

buteo-sync-plugins-sailfisheas      0.0.7-1.3.5     **>** 0.0.7-1.3.1
libsailfish-eas                     0.4.15-1.12.6   **>** 0.4.17-1.12.1
libsailfish-eas-common              0.4.15-1.12.6   **>** 0.4.17-1.12.1
qmf-eas-plugin                      0.3.4-1.9.5     <   0.3.5-1.10.2
qmf-eas-plugin-all-translations-pack 0.6.1-1.6.4    **>** 0.6.1-1.6.2
sailfish-eas                        0.4.15-1.12.6   **>** 0.4.17-1.12.1

sailfish-weather:

sailfish-components-weather-qt5             1.0.5-1.10.4  **>** 1.0.5-1.10.1
sailfish-components-weather-qt5-all-translations-pack 0.6.1-1.6.2 **>** 0.6.1-1.6.1
sailfish-weather                            1.0.0-1.5.3   **>** 1.0.0-1.5.1
sailfish-weather-all-translations-pack      0.6.1-1.6.4   **>** 0.6.1-1.6.1

xt9:

jolla-handwriting           0.1.1-1.2.7 **>** 0.1.1-1.2.3
jolla-xt9                   0.5.9-1.2.7 **>** 0.5.9-1.2.3
jolla-xt9-cp                0.2.8-1.3.7 **>** 0.2.8-1.3.3
patterns-sailfish           xt9-0.0.5-1.3.4 **>** 0.0.5-1.3.1

I can't see any pattern which would indicate intentional regression omitts. To me it looks unintentional. Thanks for clarification!

-harry

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by coderus
close date 2019-05-09 00:07:16.796521

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-09 00:06:53 +0300

coderus gravatar image

updated 2019-05-09 00:08:33 +0300

release number (after dash) doesnt matter. this is internal info means rebuild cycles for current version

also you have some mistakes in comparing which version is higher is some packages.

edit flag offensive delete publish link more

Comments

Thanks for your quick response! I don't really understand the versioning though, at least not the right-hand-side of the dash, but if you tell me that only the left-hand-side describes the project's version, I'm fine and I trust that there's no mistake at jolla-repos-site/config with Hossa. Thanks, -harry

Sunny ( 2019-05-09 09:22:04 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2019-05-08 23:37:18 +0300

Seen: 332 times

Last updated: May 09