Ask / Submit
0

Google Play Store disappeared on Sailfish X 2.2.0.29 Xperia X

asked 2019-05-15 16:49:02 +0300

RobNas gravatar image

updated 2019-05-15 17:25:22 +0300

I've installed the Play Store using these instructions:
https://it.toolbox.com/blogs/jeffhoogland/howto-google-playstore-on-sailfish-x-102517
After I installed Whatsapp and installing a Whatsapp backup, somewhere it asked me to update the Play Services, which I declined. After that, Whatsapp is available, the Play Store disappeared and trying to install it by redoing the apkd-install Phonesky from the Google Play Store installation page didn't succeed.

At this moment I'm going to update to 3.0.0.8, hopefully that'll solve something.

EDIT: updating to 3.0.0.8 didn't solve it.

edit retag flag offensive close delete

Comments

Any particular reason for not trying this method in the first instance? link text Unfortunately if something goes wrong you may have no option other than to set up again upon a newly formatted device, as very easy to get out of memory issue when installing. Whilst personally I would never use Whatsapp have never had problems with allowing Play Services to update if prompted.

aspergerguy ( 2019-05-15 18:05:47 +0300 )edit

I've used the method in your link (touch/chattr), but without succes. It still updates after a while.

RobNas ( 2019-05-16 13:55:04 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-15 18:11:42 +0300

RobNas gravatar image

updated 2019-05-15 19:00:33 +0300

After a while, Play Store magically appeared again. Next issue is apps don't download in the playstore ...
Updating Sailfish X to Hossa (3.0.3.9) now. Apps don't download ("download pending") is solved by removing google play store, reinstall phonesky and prevent it from updating:
touch /data/app/com.android.vending-2.apk and chattr +i /data/app/com.android.vending-2.apk.

edit flag offensive delete publish link more

Comments

Ehhhh from some time ago, all android subsystem is on system.img file in /opt/alien/ so this tutorial will never work again ... there is another tutorial form make play service working but I am affraid that this is a fragile a bit of hope because Sony Xperia X have android 4.4 base on XA2 is 8.1

Stanislav1988 ( 2019-05-15 19:32:33 +0300 )edit

If android subsystem is on system.img file in /opt/alien/, what needs to be changed in the tutorial to have it working again?

RobNas ( 2019-05-16 13:56:12 +0300 )edit

tutorial look here for your anserw, but fist check if you have this file system.img or android subsystem in your SFOS isn`t compressed

Stanislav1988 ( 2019-05-16 14:20:54 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-05-15 16:49:02 +0300

Seen: 158 times

Last updated: May 15