Ask / Submit
0

Sailfish SDK fails to compile new SailfishOS Qt Quick Application

asked 2019-05-16 20:17:12 +0200

mynameisnotimportant gravatar image

updated 2019-05-16 22:33:24 +0200

martyone gravatar image

I though I would try to learn how to write apps for SFOS, something really simple for a start like a life counter for Magic the Gathering maybe (essentially just a way to add numbers).

I followed the official instructions, and after creating a project trying to compile and run the application on the emulator gives me a really unhelpful error under 'Compile Output':

18:03:35: Configuration is faulty. Check the Issues view for details. Error while building/deploying project Untap (kit: SailfishOS-3.0.3.9-i486 (in Sailfish OS Build Engine)) When executing step "qmake"

Of course, the issues view is completely empty. Does anyone have any idea what I am doing wrong? Thanks.

EDIT: OS is Linux (Arch to be precise). SDK is installed in /opt/SailfishSDK, project is in a new subfolder I made in /tmp, the Alt Source Folder is pointing to my home directory.

edit retag flag offensive close delete

Comments

Which platform is this on? What is the installation path of the SDK, the project directory and the Alt source folder found under Options > Sailfish OS > Build Engine? Any message reported under the General Messages pane? Did you ever use an older version of Sailfish SDK before? If so, there may be some configuration bits that were not updated properly - try to remove ~/.config/SailfishOS-SDK (Linux/macOS). You can also try running Qt Creator from terminal (Linux/macOS) or under debugger (Windows) to check if it issues some errors on stderr.

martyone ( 2019-05-16 21:40:43 +0200 )edit

OS is Linux (Arch to be precise). SDK is installed in /opt/SailfishSDK Project is in a new subfolder I made in /tmp. The Alt Source Folder I am not what it's used for, but it's pointing to my home directory. General Messages is empty. I installed this a few weeks ago, shortly before the Hossa update. I removed ~/.confid/SailfishOS-SDK and tried again, but appart from reseting my theme preferences for the SDK nothing changed; I still get the error.

Running it in a terminal and trying to compile makes this line appear however:

SOFT ASSERT: "m_registeredCategories.contains(task.category)" in file ../../../../sailfish-qtcreator/src/plugins/projectexplorer/taskhub.cpp, line 148

mynameisnotimportant ( 2019-05-16 22:28:50 +0200 )edit

It is definitely not going to work with sources under /tmp directory. Sources need to be under home or the Alt source folder. So please try to create a project under your home. I would also consider reinstalling the SDK using the default installation path (and default Alt source folder as you did) or at least using some path under the home directory - this is the most tested scenario.

martyone ( 2019-05-16 22:45:03 +0200 )edit

/opt is (or should be) fine, I have write access to it (and in fact managed to use the SDK before without issues). Changing the project location to a subfolder of my home directory worked. So thanks for that. May I ask why though? /tmp is a writable path and no other application gave me problems with it, I use it quite a lot for things I may or may not keep (screenshots, quick edits of stuff or projects I am not sure will actually work).

Btw if you convert your previous comment into an answer I think I can mark it as 'the answer' :)

mynameisnotimportant ( 2019-05-17 00:44:52 +0200 )edit

The requirement for using something like workspace directory where all project sources need to be available from comes from the fact that the build happens under the build engine virtual machine and the shared folder mechanism of VirtualBox is used to make the sources available there. It would not be a good idea to share '/', so some specific subtree need to be picked. Please do not forget to accept the answer.

martyone ( 2019-05-17 09:03:48 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2019-05-17 08:56:56 +0200

martyone gravatar image

It is definitely not going to work with sources under /tmp directory. So please try to create a project under your home and see if it helps.

Project source code needs to be under user home directory or the Alternate Projects Folder selected during installation (defaults to user home directory) or changed later inside Qt Creator under Options > Sailfish OS > Build Engine > Alt source folder. This concept is similar to workspaces under Eclipse for those who are familiar with.

Note that using installation path outside of user home directory is not tested thoroughly - it is better to avoid that.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-05-16 20:17:12 +0200

Seen: 315 times

Last updated: May 17