SDK removes SSH keys for HW devices on upgrade

Tracked by Jolla

asked 2019-05-16 21:10:56 +0300

attah gravatar image

updated 2020-05-28 20:07:13 +0300

When upgrading the SDK through the maintenance tool, it complains that a folder it wants to remove isn't empty. The choices are retry or ignore. If I empty the folder manually, obviously the keys are removed, so this time around i tried "ignore" fully expecting the update to fail. But it didn't... however i still had to re-authorize the SDK to my device (i.e. give the password so that it can install its keys).

It's getting tiresome to have to re-setup this for every SDK update, any chance it can be fixed?

OS: Linux (Mint 19)

Screenshots from 2.2:

image description

I clicked Ignore, but still got: image description

Update 2020-05-28: This just keeps on breaking and breaking.

And the suggestion by @martyone to rely one already-deployed keys has broken itself too. I just now had the situation where "Test" form "Options/devices" aka "Manage Targets", would pass, but it would still complain about being unauthorized.

Is there a lack of dogfooding at Jolla, or am i doing something wrong?

edit retag flag offensive close delete

Comments

2

@attah thanks for reporting, under investigation

martyone ( 2019-05-16 21:31:55 +0300 )edit
2

The fix is planned for SDK 2.3. Anyway, since SDK 2.2, Qt Creator will be able to use your default key, so if you authorize that one (ssh-copy-id to your device), the issue will basically disappear for you.

martyone ( 2019-07-31 12:40:54 +0300 )edit

Thanks for the update and info. :)

attah ( 2019-07-31 12:43:21 +0300 )edit

SSH key handling is still pretty flaky. Currently it is not possible to "use your default key", i.e. unchecking deployment of new keys during the setup fails it later.

attah ( 2020-01-10 20:52:48 +0300 )edit

After the next SDK release (3.2), Qt Creator will not be using its own keys anymore.

martyone ( 2020-05-29 08:00:56 +0300 )edit