Ask / Submit
2

Microsoft exchange not syncronizing

asked 2019-05-17 06:58:35 +0200

hades01 gravatar image

updated 2019-05-17 09:31:55 +0200

jiit gravatar image

Not a deal breaker, but my hotmail (in Microsoft exchange account) is not syncing at all. normal mail does the job. but if I'd depend on this... I'd say i just threw away 30 euros to the garbage... could've used em for food or some s#@+. really, sometimes disappointing. at the beginning it worked, somehow along the way nothing. tried several settings and nothing . y'all got me really thinking on going back to iOS or Android for the sake of certain basic needs .

edit retag flag offensive close delete

Comments

Well, it would quite help if you would share some information on your configuration etc.

bomo ( 2019-05-17 08:51:16 +0200 )edit

Certainly. I do apologize. Due to the frustration I didn't even explained myself clearly and properly. When I configured my phone for the first time (XA2 Ultra running 3.0.3.9 (HOSSA)), first thing I did was go to settings>accounts and add all the ones I needed. Everything worked out properly, got my mails & contacts synced on the phone. 3/4 days ago started noticing I did receive mails from my Gmail account, however MS exchange was empty. Logged in over the web browser to find around 45 unread mails I never received. So, I deleted the account and tried syncing again... did it like 5 times, this time seems to be working, but still worried it'll stop working out of the blue as it happened before. Please note I never meddled with the account settings nor changed anything. Please see picture for reference, that's my current configuration that got it working like 6 hrs ago.

hades01 ( 2019-05-17 18:15:11 +0200 )edit

hmmm guess I can't upload pictures yet... SMH. so this is the configuration:

email address: **@hotmail.com username: *@hotmail.com
Password:
*Domain: Address: m.hotmail.com Port: 443 Secure connection: Allowed Accept untrusted certificates: Allowed

hades01 ( 2019-05-17 18:20:57 +0200 )edit

Isn't this a known issue? I suffer myself from this on Jolla C'fied Aqua Fish with 3.0.3.9. Apparently once the Exchange plugin has been idling too long, or there are network changes, or something, the syncing stops happening automatically and won't happen even when tried manually. Rebooting the device fixes the issue for time being, but it'll happen again.

There are posts about the issue I believe.

And you'll get BS advice about reinstalling Exchange to fix it, if asking from Jolla, but you'll learn that's not a working solution when you do it.

teemu ( 2019-05-17 18:55:43 +0200 )edit
1

Thanks for your input @teemu, I did reboot the device, before deleting the account, did it like 5 times along with the manual "sync account", and sync all mail with no success. I did look through search though and found nothing on MS exchange not syncing, perhaps used wrong keywords. Anyhow, I believe this bug or issue wasn't stated on 3.0.3.9 release notes. So far I read on Jolla support to tick the "accept untrusted certificates" so, I'll report if having this on helps out on something.

hades01 ( 2019-05-17 19:25:48 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-21 14:49:42 +0200

Pliocen gravatar image

I use Outlook.com and before that I also had problems with EAS sync on XA2 Plus. First, I deleted the Exchange account, then I completely removed Microsoft Exchange applications, restart XA2, reinstall Microsoft Exchange. During automatic configuration, the server settings are downloaded: eas.outlook.com, I changed them to: outllok.office365.com and I have no problem with EAS synchronization. Also check in the e-mail settings on the computer - mobile devices, if you can see the Sailfish OS device, if it is on the right - enable logging. I hope I helped

edit flag offensive delete publish link more

Comments

Thank you for your input. I did mention @teemu I'd test and report back if a similar workaround actually fixed the issue, in my case, I changed the server settings as: m.hotmail.com and also check the "accept untrusted certificates", this seems to work as a solution for the problem. Mail's been syncing every hour with no issues so far.

hades01 ( 2019-05-21 18:41:42 +0200 )edit

I went through this on my Xperia X. I mainly used Microsoft Exchange to sync my calendar. it would sync for a day or so then stop syncing until I rebooted the phone. In the end I gave up and set up my calendar to sync using CalDAV. I've never looked back, it works well.

AlanBreen ( 2019-05-22 04:37:02 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-05-17 06:58:35 +0200

Seen: 216 times

Last updated: May 21