Ask / Submit
0

Can connect to the build vm, but not to the emulator

Tracked by Jolla (In progress)

asked 2019-05-19 22:25:27 +0200

bionade24 gravatar image

updated 2019-05-21 22:47:21 +0200

Hello,

I'm running the SDK on Arch Linux, and since it could be the problem, installed it under /opt/SailfishSDK, even though all rights seme sat right.

I also get Failed to mount FFS, if this helps. Network doesn't seem to show up in ip a, but why then does the build vm work? Other OSses are working well in Virtualbox, KVM works, too.

Any idea to help me?

Edit: ssh access works. ssh works not with the key, I always need to type in password, even after I regenerated ssh keys. MerConnection: "Failed to establish SSH conection with virtual machine \"Sailfish OS Emulator 3.0.3.9\": 5 Problem mit privatem Schlüssel: No such file or directory" QIODevice::write (Utils::SaveFile, ""): device not open SOFT ASSERT: "ok" in file ../../../../sailfish-qtcreator/src/plugins/mer/meremulatordevice.cpp, line 656 QIODevice::write (Utils::SaveFile, ""): device not open New Problem: The keys are under /opt/SailfishSDK/vmshare/ssh/ and I can solve the problem with a symlink, since I can't change the paths under devices, but I don't know where the ssh config is now. It's just missing, can't find it anywhere.

edit retag flag offensive close delete

Comments

Let's start with some basic info: Which SDK version are you using? Does the emulator start (but you are just unable to connect to it)?

vige ( 2019-05-20 07:02:37 +0200 )edit

I use the latest version, of course. And yes, the emulator starts.

bionade24 ( 2019-05-20 08:16:36 +0200 )edit

Can you connect using ssh from the command line? Try "ssh -i /opt/SailfishSDK/vmshare/ssh/private_keys/Sailfish_OS-Emulator-latest/nemo -p 2223 nemo@127.0.0.1". If not, what kind of error message does ssh give?

vige ( 2019-05-20 08:24:43 +0200 )edit

Yes, ssh acces works.

bionade24 ( 2019-05-20 18:01:22 +0200 )edit

That suggests that there is something wrong in the Qt Creator device configuration. Go to Tools->Options->Devices. Select "Sailfish OS Emulator 3.0.3.9 (default for Sailfish OS Device)". Check that the SSH port is "2223" (the same you used when connecting from command line). Try "Regenerate SSH Keys" - it sometimes helps.

vige ( 2019-05-21 10:24:27 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-21 23:18:56 +0200

bionade24 gravatar image

updated 2019-05-22 12:48:53 +0200

martyone gravatar image

Purpose:

I installed the SDK long ago under /home/user/workspace/SailfishOS and later installed it under /opt/SailfishSDK. The config for the build engine is editable and was updated with the reinstallation, but the config for the emulator survived somewhere and can't be edited in the IDE's preferences under devices.

Solution:

So I currently worked around with a symlink, but I think this issue with the IDE should be reported. Where can I submit IDE bugs?

edit flag offensive delete publish link more

Comments

https://github.com/sailfishos

but it should be spotted here as well and tracked

coderus ( 2019-05-22 00:14:21 +0200 )edit

Consider it submitted :)

vige ( 2019-05-22 07:55:58 +0200 )edit

Can't do that for my.comment until I got 20 votes.

bionade24 ( 2019-05-22 08:19:49 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-05-19 22:25:27 +0200

Seen: 206 times

Last updated: May 22