Ask / Submit
1

[XA2] [3.0.3.9] Can Not connect to Open Wifi

asked 2019-05-23 08:18:05 +0300

Raymaen gravatar image

updated 2019-08-12 09:44:56 +0300

The Browser does not open automatically. I tried a lot of open wifis but non of them worked.

Even when I open the browser manually it does Not connect to the Public wlan Login Page to sign in for free wifi.

Update: [3.1.0.11] stil not working! now even with webcat it is working only partially.

edit retag flag offensive close delete

Comments

i have the same device and the.same version, open wifi works like a charm. did you use some kind of changed dns or something?

samsy ( 2019-05-23 08:40:28 +0300 )edit

No it simply does not connect. Can I reicher the Start somehow?

Raymaen ( 2019-05-23 08:42:22 +0300 )edit
2

If it's a public captive portal, that you have to sign in to, stock browser is touchy. Webcat handles them better. Once you've signed in, Browser is fine...

Levone1 ( 2019-05-23 15:50:04 +0300 )edit
2

In my experience that happened a lot before SFOS 3. The browser rarely opened the captive portal automtacally. I had to visit an _unencrypted_ website, e.g. http://neverssl.com and then got redirected to the captive portal. Sometimes I even had to close all other apps that tried to connect to the net for the redirection to work.

Now since SFOS 3 it works much more reliably however not always. I mainly use public wifi in German trains, so I set a bookmark to manually visit the captive portal. This works as a fallback.

jollajo ( 2019-05-23 19:54:04 +0300 )edit

@Raymaen by me it works like a charm too. Please give your device referenz. Maybe it's only an issue by you. And if others have something similar, they could add themselves on your thread here

cemoi71 ( 2019-05-24 11:50:04 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-24 08:21:28 +0300

Raymaen gravatar image

updated 2019-05-24 12:16:09 +0300

I installed webcat and it works with it. jolla stock browser does not work! its a pity...

thanks @ Levone1

edit flag offensive delete publish link more

Comments

please don't used some words when you don't know if it depends on your device, or own special configuration, or eventual patches (not supported from jolla)...
You didn't give your device reference and not a detailed reproducibility. How may other people help you especially on a small part under 1000 other one?

cemoi71 ( 2019-05-24 11:53:56 +0300 )edit

please delete shame is a little bit condescending with the context.
We all learnt from parent not too use it spontaneously, but with parsimony.

cemoi71 ( 2019-05-24 12:02:30 +0300 )edit
1

i dont use open repos or other custom patch stuff. Im not techsavy, etc. im just a stock user who flashed his XA2 singlesim device with the latest 3.0.3.9 Sailfish Beta image.

Raymaen ( 2019-05-24 12:18:34 +0300 )edit

good point. I can just tell me too ;-)
& thanks for update...

cemoi71 ( 2019-05-24 14:10:44 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-05-23 08:18:05 +0300

Seen: 203 times

Last updated: Aug 12