Ask / Submit
10

Harbour is rejecting rpm package build by latest SDK

Tracked by Jolla (In progress)

asked 2019-05-25 18:46:23 +0300

Karry gravatar image

updated 2019-05-25 18:47:31 +0300

Hi.

I build my project OSM Scout with latest SDK as usual, but harbour is refusing to accept generated rpm package with this message:

No OS version and packages satisfy package requirements: 1.0.2.5 excluded by qt5-qtpositioning EQ 0:5.1.0+git21-1.12.1 1.0.6.12 excluded by qt5-qtpositioning EQ 0:5.1.0+git28-1.17.2 1.0.7.12 excluded by qt5-qtpositioning EQ 0:5.1.0+git28-1.17.5 1.0.8.19 excluded by qt5-qtpositioning EQ 0:5.1.0+git28-1.17.7 Requirement libstdc++.so.6(CXXABI_1.3.8) not available Requirement libstdc++.so.6(GLIBCXX_3.4.20) not available 1.0.2.5 excluded by qt5-qtdeclarative-import-positioning EQ 0:5.1.0+git21-1.12.1 1.0.6.12 excluded by qt5-qtdeclarative-import-positioning EQ 0:5.1.0+git28-1.17.2 1.0.7.12 excluded by qt5-qtdeclarative-import-positioning EQ 0:5.1.0+git28-1.17.5 1.0.8.19 excluded by qt5-qtdeclarative-import-positioning EQ 0:5.1.0+git28-1.17.7

Any idea what is wrong? I am not really sure from provided error message...

edit retag flag offensive close delete

Comments

1

I just removed manual dependencies from spec file: https://github.com/Karry/osmscout-sailfish/commit/fadcddb3359c5855b7b0b4dbe15052c2ee8816ec

That solves errors with Qt libraries, but errors about CXX abi remains:

No OS version and packages satisfy package requirements: 
Requirement libstdc++.so.6(CXXABI_1.3.8) not available 
Requirement libstdc++.so.6(GLIBCXX_3.4.20) not available

It is necessary to mention that I started to using c++14 standard with SDK 3.0.3 ;-)

all dependencies

# rpm --requires -qpv RPMS/harbour-osmscout-1.11-1.armv7hl.rpm 
auto: libQt5Core.so.5
auto: libQt5Core.so.5(Qt_5)
auto: libQt5Gui.so.5
auto: libQt5Gui.so.5(Qt_5)
auto: libQt5Network.so.5
auto: libQt5Network.so.5(Qt_5)
auto: libQt5Positioning.so.5
auto: libQt5Qml.so.5
auto: libQt5Qml.so.5(Qt_5)
auto: libQt5Quick.so.5
auto: libQt5Quick.so.5(Qt_5)
auto: libQt5Sql.so.5
auto: libQt5Sql.so.5(Qt_5)
auto: libQt5Svg.so.5
auto: libQt5Svg.so.5(Qt_5)
auto: libc.so.6
auto: libc.so.6(GLIBC_2.17)
auto: libc.so.6(GLIBC_2.4)
auto: libc.so.6(GLIBC_2.6)
auto: libc.so.6(GLIBC_2.7)
auto: libgcc_s.so.1
auto: libgcc_s.so.1(GCC_3.5)
auto: libm.so.6
auto: libm.so.6(GLIBC_2.4)
auto: libmdeclarativecache5.so.0
auto: libpthread.so.0
auto: libpthread.so.0(GLIBC_2.4)
auto: libsailfishapp.so.1
auto: libstdc++.so.6
auto: libstdc++.so.6(CXXABI_1.3)
auto: libstdc++.so.6(CXXABI_1.3.2)
auto: libstdc++.so.6(CXXABI_1.3.3)
auto: libstdc++.so.6(CXXABI_1.3.5)
auto: libstdc++.so.6(CXXABI_1.3.8)
auto: libstdc++.so.6(CXXABI_ARM_1.3.3)
auto: libstdc++.so.6(GLIBCXX_3.4)
auto: libstdc++.so.6(GLIBCXX_3.4.11)
auto: libstdc++.so.6(GLIBCXX_3.4.14)
auto: libstdc++.so.6(GLIBCXX_3.4.15)
auto: libstdc++.so.6(GLIBCXX_3.4.18)
auto: libstdc++.so.6(GLIBCXX_3.4.19)
auto: libstdc++.so.6(GLIBCXX_3.4.20)
auto: libstdc++.so.6(GLIBCXX_3.4.9)
auto: libxml2.so.2
auto: libxml2.so.2(LIBXML2_2.4.30)
auto: libxml2.so.2(LIBXML2_2.6.0)
auto: libxml2.so.2(LIBXML2_2.6.5)
rpmlib: rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib: rpmlib(FileDigests) <= 4.6.0-1
rpmlib: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib: rpmlib(PayloadIsXz) <= 5.2-1
Karry ( 2019-05-28 08:59:34 +0300 )edit

Same for me. Harbour refuses the package with the following message:

No OS version and packages satisfy package requirements: 
Requirement libstdc++.so.6(GLIBCXX_3.4.20) not available

And as Karry I also started using C++14.

Buschmann ( 2019-06-06 13:15:24 +0300 )edit

Any news about this?. I get No OS version and packages satisfy package requirements: Requirement libstdc++.so.6(GLIBCXX_3.4.20) not availablemessage when uploading my Fastchess application. Code can be found https://github.com/Rikujolla/shakkikello. I have not changed my C++ part of the code recently. EDIT 20th June 19, now it works, thanks!

Rikujolla ( 2019-06-19 16:19:20 +0300 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2019-06-19 23:21:20 +0300

Keto gravatar image

The 3.0.3 ABI has now been imported in the Harbour intake and all the required capabilities should be there.

Sorry for not noticing this earlier.

edit flag offensive delete publish link more

Comments

Nice. Works for me.

Buschmann ( 2019-06-21 10:54:23 +0300 )edit

Thank you! It works now.

Karry ( 2019-06-21 12:59:32 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2019-05-25 18:46:23 +0300

Seen: 430 times

Last updated: Jun 19