Ask / Submit
1

XA2 Plus (4493) - SFOS 3.0.0.10 - Browser stopped working (whirls and closes)? [answered]

asked 2019-06-02 21:53:55 +0300

PeegeeTips gravatar image

updated 2019-06-02 23:57:09 +0300

Hi there,

If I open the browser, i get the minimised app card appear on screen with the expected whirly progress symbol. But instead of resulting in an open full screen browser the minimised app card then disappears, leaving me on the multitasking pane.

This behaviour has persisted beyond a restart of the device. It has also persisted beyond the removal of a number of Storeman apps (and their repos).**

** never installed much from Storeman: Storeman itself, Maps.me, Recorder, and apparently curl and libcurl (had for months with no issues) More recently installed Maep and GPSinfo, FBReader, Sailfish Connect, Talefish (and one or two others, now all removed)...

...and Terminal, as i did try running the devel-su command as part of a trio to try a fix suggested elsewhere, but the terminal didn't know what to do with the command (and frankly i'm not confident enough to pursue it).

Any thoughts?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Asmir
close date 2019-06-16 07:29:23.555215

Comments

Oh, I had the same issue after hanging tabs. Try to open any link from other apps. If browser runs, then close the last tab.

Asmir ( 2019-06-03 00:43:46 +0300 )edit

thanks, i have tried using quickdit and Tweetian to open the browser, but both fail with the same response.

PeegeeTips ( 2019-06-03 10:01:14 +0300 )edit

Bumped in to the same issue today, browser would crash on start if launched from the App Drawer, no external links could be opened. Rebooted and now it's working. Quite annoying issue. I'll also try to gather some logs if (when) this happens again.

raketti ( 2019-06-03 13:23:45 +0300 )edit

I've had this a few times too. Last time it was cleared with setting "close all tabs on exit" and Utilities/Restart home screen.

potski ( 2019-06-04 10:37:57 +0300 )edit

@ raketti - i've tried a reboot a few times now to no effect. :)

@ potski - i've tried this too with no effect. browser still crashes. thanks. :)

PeegeeTips ( 2019-06-04 11:50:33 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-06-03 00:06:17 +0300

Maus gravatar image

Removing (or renaming) your browser's settings and cache from Terminal is my first idea when I encounter problems like this. From Terminal, just enter

mv .mozilla .mozilla-backup

and try to start your browser. If it doesn't work, you can restore the old status with

rm -rf .mozilla ; mv .mozilla-backup .mozilla
edit flag offensive delete publish link more

Comments

tried that command in the terminal, but no effect. so ran the second one to return things to the status-quo ante.

p.s. there was no response in the terminal to running these commands (maybe there shouldn't be - and at least no error response - but thought i'd mention it).

where next, try Neverareeee's suggestion reinstalling the browser?

kind regards. PeegeeTips

PeegeeTips ( 2019-06-04 11:51:34 +0300 )edit
1

answered 2019-06-02 23:58:13 +0300

Nerevareeeeeee gravatar image

I'm not a pro by any mean Have you tried starting sailfish-browser from terminal? Usually program will tell what's broken. Maybe reinstall will fix it devel-su pkcon install sailfish-browser

edit flag offensive delete publish link more

Comments

hmmm, tried this in terminal and the error reponse was: "bash: devel-su: command not found

PeegeeTips ( 2019-06-03 10:00:30 +0300 )edit
  • password problem solved

i figured out that developer mode needs to be enabled to do this, and now the command does not error out.

however, after initiaiting the command it asks for a password.... which is what precisely? (it doesn't appear to the device-lock pin code...)

PeegeeTips ( 2019-06-04 14:09:04 +0300 )edit

problem solved - thank you. browser back

PeegeeTips ( 2019-06-04 14:14:25 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2019-06-02 21:53:55 +0300

Seen: 164 times

Last updated: Jun 03