Ask / Submit
2

Problems with openvpn (Sailfish 3.0.3.10)

asked 2019-06-04 08:26:40 +0300

as400 gravatar image

I have problems connecting to my openvpn server both with gui and command line. When I try to connect from command line with nemo user I get: "Cannot open TUN/TAP dev /dev/net/tun: Permission denied". Running the same command with root connects successfully. Anyone with similar problems ?

edit retag flag offensive close delete

Comments

what similar problem?! - regarding not able to open the tun/tap device from nemo user it is clear. you should be root to do that. Perhaps you are missing some elevation rules. I should admit I never tried to contact the vpn server from the phone.

deloptes ( 2019-06-06 00:16:16 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-06-04 12:05:41 +0300

Marzanna gravatar image

Try SecureFishNet from OpenRepos. I found built-in VPN client very unreliable.

edit flag offensive delete publish link more

Comments

SecureFishNet also doesn't work.

as400 ( 2019-06-04 12:46:49 +0300 )edit
0

answered 2019-06-04 17:03:07 +0300

deprecated gravatar image

updated 2019-06-04 17:03:16 +0300

chmod 660 /dev/net/tun

That has fixed it in the past, perhaps it'll fix it for you now.

edit flag offensive delete publish link more
0

answered 2019-06-05 00:10:36 +0300

SaimenSays gravatar image

For me it works, also with 3.0.3.10. But setup was done long time before with imported .ovpn file, including the keys.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2019-06-04 08:26:40 +0300

Seen: 350 times

Last updated: Jun 05