Ask / Submit
0

Sailfish sdk requires build target version update to SailfishOS-3.0.3.10

asked 2019-06-04 09:43:51 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-06-04 09:52:43 +0200

venki gravatar image

In the Latest sdk(Qt Creator 4.8.1 (Sailfish SDK)) ,The Build Target still points to SailfishOS-3.0.3.9.

edit retag flag offensive close delete

Comments

what the point of updating target version for you?

coderus ( 2019-06-04 11:04:07 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-06-04 11:05:13 +0200

martyone gravatar image

The differences between 3.0.3.9 and 3.0.3.10 are not relevant at build time. 3.0.3.9 build tools can be used to build software for 3.0.3.10 targets. It is not planned to provide 3.0.3.10 build tools.

edit flag offensive delete publish link more

Comments

This means , i can deploy apps to phone(Sailfish-3.0.3.10) with the same sdk ?

venki ( 2019-06-04 14:04:18 +0200 )edit

Yes. Furthermore, for applications that comply with Jolla Harbour rules, forward compatibility is guaranteed to certain extent, i.e., packages built with an older SDK remain usable with newer OS releases.

martyone ( 2019-06-04 14:31:20 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-06-04 09:43:51 +0200

Seen: 150 times

Last updated: Jun 04